Scribusoid

Author Topic: pdf/x-1a output  (Read 3884 times)

Veldman

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
pdf/x-1a output
« on: August 02, 2013, 08:09:04 pm »
Hi,
My printshop asks for pdf/x-1a format, because of incompatibility with PDF/x-3.
As I understand after reading the forum and wiki, it this is not possible in Scribus, or is it?
Is there a workaround?

I'm using 1.4.3 on Windows7.

utnik

  • Hero Member
  • *****
  • Posts: 1306
  • Karma: 14
Re: pdf/x-1a output
« Reply #1 on: August 02, 2013, 09:43:32 pm »
hi veldmann

.pdf/x-1a export will be implemented in scribus1.6 – it allready works in 1.5svn.
i've installed scribus1.5 exactly for this purpose. but i never do the whole layout work in this development release…

utnik

Veldman

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: pdf/x-1a output
« Reply #2 on: August 03, 2013, 10:46:02 am »
Ok, thank you, but were can I find 1.5svn for Windows?

leaf

  • Jr. Member
  • **
  • Posts: 88
  • Karma: 0
  • Scribus User
Re: pdf/x-1a output
« Reply #3 on: August 03, 2013, 11:19:02 am »
Ok, thank you, but were can I find 1.5svn for Windows?

You can't find 1.5 svn for Windows yet, but if you want install virtual machine with ubuntu, lubuntu, mint and in console paste
sudo apt-add-repository ppa:scribus/ppa

sudo apt-get update

sudo apt-get install scribus-trunk

robert leleu

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: pdf/x-1a output
« Reply #4 on: August 10, 2013, 04:37:56 pm »
Trying to install Scribus in Mint Olivia 64 Mate the 3d instruction fails :

leleu@portable-leleu ~ $ sudo apt-get install scribus-trunk
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package scribus-trunk
leleu@portable-leleu ~ $

Synaptic sees only the "stable branch" and thi ppa is http://ppa.launchpad.net/scribus/ppa/ubuntu/

So from https://launchpad.net/~scribus/+archive/ppa/+build/4854230 I downloaded scribus-trunk_1.5.0svn201308060505-24~raring1_amd64.deb who complains that it needs libgraphicsmagick3 (>= 1.3.5)

I downloaded this last package from http://packages.ubuntu.com/fr/lucid/amd64/libgraphicsmagick3/download installed it
...libopenscenegraph

etc…

My conclusion : raring is not ready for Scribus 1.5



Veldman

  • Newbie
  • *
  • Posts: 5
  • Karma: 0
  • Scribus User
Re: pdf/x-1a output
« Reply #5 on: August 13, 2013, 04:56:02 pm »
I got Scribus 1.5 running in Ubuntu under Virtual Box in Windows 7. (For some reason I could only run the 32bit Ubuntu, although I have Windows 7 & Virtualbox in 64bits.)
The instructions provided by leaf didn't work at first (don't remember wich error I got, but something got wrong at the end).
I then installed the regular version (1.4.3) from the Ubuntu Software Center. That did go well.
Then I retried leaf's instructions and hurray; it worked!

But alas, for some reason there wasn't an option to save as pdf/x-1a, so it was of no use to me.

I didn't look any further for a solution because in the meantime the kind people at the printshop examined a pdf v1.3 output that I send them and that was perfect.

utnik

  • Hero Member
  • *****
  • Posts: 1306
  • Karma: 14
Re: pdf/x-1a output
« Reply #6 on: August 13, 2013, 07:55:11 pm »
hi veldman

you need to activate the color management ('file' → 'document setup' → 'color management' → 'activate color management') – then the .pdfx-1a, x-3 and x-4 are available.
with 'preferences' → 'color management' → 'activate color management', you can activate it for all new files. but this is more useful in the stable version, at least as long as you do your layout work there (as recommended) and only load it in scribus1.5 for generating the .pdf file if x-1a or x-4 is required…

utnik

rascalsmom

  • Newbie
  • *
  • Posts: 39
  • Karma: 0
  • Scribus User
Re: pdf/x-1a output
« Reply #7 on: August 24, 2013, 04:44:50 am »
you need to activate the color management ('file' → 'document setup' → 'color management' → 'activate color management') – then the .pdfx-1a, x-3 and x-4 are available.

Thank you! I just installed 1.5 today for the PDF/X-1a:2001 capability (that and creating tables). I couldn't figure out why those choices weren't highlighted in the dropdown list. In fact, I came to the forum searching for the answer. Thanks, utnik