Scribusoid

Author Topic: Align shape to line (center on horizontal axis): odd result  (Read 3820 times)

TheCatProblem

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Hello,

When I attempt to center a shape on the horizontal axis of a line with non-hairline thickness using the Align and Distribute window, the central horizontal axis of the shape is positioned collinear with the bottom edge of the line (see attached image and SLA file).

My exact procedure is as follows:
- Select line.
- Shift-select shape (a rectangle, in this case).
- Click the "Center on horizontal axis" button in the Align and Distribute window.

Is this a bug? It seems that the y coordinate of the centre of the line (for alignment purposes) is being computed as the line's y position plus half the line width, as the same behaviour occurs consistently for any line with a thickness greater than hairline.

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: Align shape to line (center on horizontal axis): odd result
« Reply #1 on: July 04, 2013, 03:39:28 pm »
I'd say this is a bug.

Following the workflow suggested (on Scribus Version 1.4.2, 13 January 2013, Build ID: C-C-T-F-C1.12.8-Mac/Aqua, Using Ghostscript version 8.71) gives me the same unexpected result.

However, when the line is vertical the rectangle is centred correctly. Also, when the line is at any angle other than 0 degrees it also seems to centre correctly on the horizontal - even at 180 degrees.

Aligning the bottom of the rectangle to the horizontal line also gives a result that looks wrong (when the line is at 0 degrees) while aligning the top of the rectangle works correctly as expected.

See attached screenshot for examples. (The X is an empty image frame. Forget the missing frame border, that's a known OSX issue apparently fixed for 1.4.3.)

GarryP

  • Hero Member
  • *****
  • Posts: 1600
  • Karma: 25
  • Scribus User
Re: Align shape to line (center on horizontal axis): odd result
« Reply #2 on: July 07, 2013, 10:30:07 pm »
I can confirm that the same problem is exhibited on Scribus Version 1.4.1.svn, 6 February 2012, Build ID: C-C-T-F-C1.12.14, Using Ghostscript version 9.07 on Ubuntu 13.04.

I've created a bug report http://bugs.scribus.net/view.php?id=11647 for this.

TheCatProblem

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Align shape to line (center on horizontal axis): odd result
« Reply #3 on: July 09, 2013, 04:39:58 pm »
Thanks for following up with this, Garry.