Author Topic: Failed to open or import pdf files  (Read 660 times)

Gorgoyle9

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
  • Scribus User
Failed to open or import pdf files
« on: March 09, 2021, 07:02:55 pm »
I would like to open or import pdf or eps files but there is
ghostscript fatal error. Help.

mnawij

  • Sr. Member
  • ****
  • Posts: 339
  • Karma: 1
  • Scribus User
Re: Failed to open or import pdf files
« Reply #1 on: March 10, 2021, 03:06:22 am »
Hi Gorgoyle9,

To help further, What operating system? Which version of Scribus? Which version of ghostscript installed?

Thanks!

mnawij

Philogos

  • Newbie
  • *
  • Posts: 3
  • Karma: 0
  • Scribus User
Re: Failed to open or import pdf files
« Reply #2 on: November 17, 2021, 11:56:47 pm »
Help.
I have had the same problem with importing PDF file into Scribus 1.4.8 on Windows 11. I have tried a number of PDF files, including some that worked on previous versions of Scribus and a postscript generated as a Scribus export. Same result or Scribus just stops talking to me.

PostScript import failed when calling gs as:
-q -dNOPAUSE -dNODISPLAY -dBATCH -dDELAYBIND -g5472x3456 -r288 -dTextAlphaBits=4 -dGraphicsAlphaBits=4 -c 0 0 translate -sTraceFile=C:\Users\vic_h\AppData\Local\Temp\\\ps.out -sExportFiles=C:\Users\vic_h\OneDrive\Napoleon\Documents\Projects\Books\20211113 Teheran\Document--9780956343079-Perfect C:\Program Files (x86)\Scribus 1.4.8\libs\import.prolog C:\Users\vic_h\OneDrive\Napoleon\Documents\Projects\Books\20211113 Teheran\9780956343079-Perfect.pdf -c flush cfile closefile quit

Ghostscript diagnostics:

        GPL Ghostscript 9.55.0: Unrecoverable error, exit code 1

        ant Ghostscript

                       to execute in a safer environment, but at the same time

                       have selected DELAYBIND. Unless you use this option with

                       care (and specifically, remember to call .bindnow) it is

                       possible that malicious code may be able to evade the

                       limited security offered by the SAFER option.

        Error: /undefined in GS_PDF_ProcSet

        Operand stack:

           false

        Execution stack:

           %interp_exit   .runexec2   --nostringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--
           --nostringval--   --nostringval--   false   1   %stopped_push   1990   1   3   %oparray_pop   1989   1   3   %oparra
        y_pop   1977   1   3   %oparray_pop   1834   1   3   %oparray_pop   --nostringval--   %errorexec_pop   .runexec2   --no
        stringval--   --nostringval--   --nostringval--   2   %stopped_push   --nostringval--

        Dictionary stack:

           --dict:1213/1684(ro)(G)--   --dict:0/20(G)--   --dict:76/200(L)--

        Current allocation mode is global

        Current file position is 2261

 

palmate