Recent posts

#11
Beginner Talk / Re: Pagination of large docume...
Last post by a.l.e - February 24, 2024, 02:28:27 PM
I have now added (ok, created) a mod with a [SOLVED] button, you can use to mark a topic as solved.

You're welcome to try it out : - )
#12
Free discussion / Re: Writing a book with scribu...
Last post by Nermander - February 24, 2024, 02:19:37 PM
I would say that since Scribus is mainly a page layout program, it is not very suitable for writing in.

Also footnotes and index are things that Scribus does not really handle well yet. Table of contents is (at least was, the last time I looked) frame based in Scribus, not based on headings as in most other programs.
#13
Windows / Re: The application lilypond -...
Last post by Nermander - February 24, 2024, 02:16:24 PM
Can you run "lilypond" from the command line?

If it is not in the path, I think you need to enter the full path to the executable in:
Preferences -> External tools
#14
Windows / The application lilypond --pdf...
Last post by Florestan - February 24, 2024, 01:56:57 PM
Dear forum,

I have installed Scribus on my Win11 computer and would like to use Lilypond in the render frame.

Lilypond itself is also installed. Now when I drag a render frame, I always get the message: "The application lilypond --pdf" could not be started. Please check the path:" (The message also ends after the colon, Scribus does not tell me which path it wants to check...) The programme then crashes.

Maybe it's because I didn't install Lilypond in the default Applications folder. But I can't find a way to change the path anywhere.

Or is this perhaps a programming error?

Thank you for your help!
#15
Free discussion / [SOLVED] Writing a book with s...
Last post by oida - February 24, 2024, 12:54:44 PM
Hallo,

i know the title is a little bit provocative, but let me introduce my self first. I'm a retired photographer and enthusiastic homechef and was asked to give a lot of my recipes to friends. So i want to recap most of my recipes in a small cookbook, which i can give as a gift to my friends.

For yrs i'm on the DebianLinux  ;D  side and so i have Libreoffice (7.2) and Scribus (1.5.8) already on my desk. In the past i used Scribus only for designing onepage flyers and that worked well for me. My knowledge og LO Writer is a little above basic.

The recipes are partly in Libreoffice, partly handwritten so i had to (re)type almost all of them, but that's ok for me.

So, what are the facts:

The book will end up with appx. 100 - 150 pages(recipes, each is one page with a picture, and should include a table of contents and a index, but also some footnotes and, important, a index of incredients (for example G - garlic - pg. xx,yy,zz ...).

I know how the book should look, which format, letter size, layout etc, and it seems that booth programs are fullfilling my needs. Since i have to dive deeper in one of the programs i am struggling which one to use, so hopefully some of you have recommendations for me.

Thank you all in advance for any help and stay safe

PS: Pls excuse my bad english, but my mother language is german (i live in Austria)
#16
General Discussion / Re: Debian Still on 1.5.8
Last post by Nermander - February 23, 2024, 08:31:29 PM
1.6.1 was released less than a month ago, I think it is fully understandable that it is not yet included in Debian.
#17
General Discussion / Re: Debian Still on 1.5.8
Last post by a.l.e - February 23, 2024, 06:18:37 PM
From the Scribus page @ Debian

https://tracker.debian.org/pkg/scribus

it seems that the maintainer is active and Debian knows that Scribus 1.6.1 is out.

I can guess what could be the reasons are for the delay, but it might as simple as him being busy with life and since

a. 1.5.8 is not much different from 1.6.1,
b. he had to struggle for years to keep Scribus in Debian while Scribus was not releasing for many yaers,

upgrading to 1.6.0 is not one of his main priorities.

I guess that, for now, there is not much you can do... except becoming a Debian developer : - )
#18
General Discussion / Debian Still on 1.5.8
Last post by MattMiller - February 23, 2024, 05:30:11 PM
The Debian Linux distribution is still offering version 1.5.8. Even their "sid" development version has this. Can I file a bug report or something with them to get them to package 1.6x? If I go to to their standard bug reporting tool it offers a way to post a bug against their 1.5.8 version, but I'm looking for a way to let them know I want 1.6.1.

Any suggestions?
#19
Beginner Talk / Re: Some questions about Footn...
Last post by a.l.e - February 22, 2024, 03:51:31 PM
hi

nice to see somebody testing the notes BEFORE using them in production!

as you might have noted, they're still an experimental feature and not all features are there and not everything works as one would expect.

about your questions:

1. a "story" is a set of linked text frames. i guess there is no need to define a document : - )

2. i think that scribus should have a third option in the range: section. since this option will not be there for some time, as a workaround you could define a different "note style" for each chapter. (i've added a ticket: https://bugs.scribus.net/view.php?id=3349)

3. the best way to import formatted text is to load the file into the text frame. i did not test, but i guess that you did. the best formats to import from being odt, html and probably idml. sadly, if the import from libreoffice does not recognize the footnotes, then i fear that there is not much you can do. (see https://bugs.scribus.net/view.php?id=15673 if you want to feel a bit less alone)

currently, there is nobody who is working on the footnotes, so i fear that in the near future there is no progress to be expected.
#20
Beginner Talk / Re: Pagination of large docume...
Last post by AdmFubar - February 21, 2024, 11:08:11 PM
Quote from: bigal on February 21, 2024, 07:07:42 AMMachine details are as follows.

Info:
  Processes: 245 Uptime: 10m wakeups: 0 Memory: 2.9 GiB used: 1.56 GiB (53.9%) Init: systemd
  v: 249 runlevel: 5 Compilers: gcc: 11.4.0 alt: 11/12 Client: Unknown python3.10 client
  inxi: 3.3.13



if i'm reading this right, 3gb of ram? there is the problem