Scribusoid

Recent Posts

Pages: 1 2 3 4 5 6 7 [8] 9 10
71
Linux / Re: Scribus 1.5.7 cannot 'see installed GIMP 2.10.28 Mint 20.2 Cinnamon
« Last post by Nermander on October 30, 2021, 12:47:38 pm »
Just go to Preferences->External tools and set the path to the GIMP executable (you can browse to it using the Change button).
72
Linux / Scribus 1.5.7 cannot 'see installed GIMP 2.10.28 Mint 20.2 Cinnamon
« Last post by LateJunction on October 29, 2021, 02:14:33 pm »
When I attempt to edit an image in Scribus 1.5.7 I get the error message "The program gimp is missing or failed to open". The installed, and working, version of GIMP on my Mint 20.2 Cinnamon PC is 2.10.28. I should add that GIMP is a flatpak version as that is the only option available from the GIMP website (attempting to compile from source is a waste of time, for me; the version of GIMP in the Mint repositories, available via Synaptic, is too old).

I guess is that Flatpak has installed GIMP  in a place which Scribus does not check. Can I adjust this from within Scribus?
73
Installation and Setup / Re: 1.5x Catalina Not Launching
« Last post by toyotadesigner on October 29, 2021, 12:43:12 pm »
Just for the record: I am running Scibus 1.5.8 SVN Revision 24739 on a 27" iMac from 2013 with macOS Catalina 10.15.7 (19H1519) without any problems. I even use it for commercial work for my own collaterals to be printed professionally.

I have some 2,300 professional Open Type Fonts on my system, no problem with those. In addition, I have downloaded and installed the latest Ghostscript-9.55-Full here: https://pages.uoregon.edu/koch/

Everything is working flawlessly, even with large 16 bit TIFF files.

Just to say that Scribus is stable and running on a Catalina system.
74
Installation and Setup / Re: 1.5x Catalina Not Launching
« Last post by digirew on October 28, 2021, 04:59:03 pm »
Try deleting your prefs and let scribus recreate them.

/Users/username/Library/Preferences/Scribus

Simply delete that Scribus folder and relaunch the scribus.app.


Note, you will need to use the go menu on the finder, and then select "go to folder"... as its a hidden folder.
75
General Discussion / Re: Scribus immediately crashes
« Last post by AdmFubar on October 28, 2021, 12:33:02 am »
Looks like you are missing some files on your system, and there are some errors in the scribus configuration dir.. this could be caused by a bad hard drive. I would rename the .scribus directory and see if it rebuilds the configuration. that may clear up the problem.
In the mean time what os and system specs can you share? plus how old is your system?
76
Recently I placed a complex SVG graphic in one of my documents. When I select the graphic, there is no pink background. When I double-click the graphic, the nodes appear, but no pink background.

There is no pixelation of the graphic at all, neither in normal view nor in ┬╗Preview Mode┬ź, no matter how far I zoom in, and not even in the exported PDF/X-4 file.
77
OK.... I feel like a bit of a fool. I now realize there was nothing wrong with the background color and the light pink only represents that the graphic is selected and can be edited. Oddly, before posting I searched online and within this forum for "scribus + vector + light pink background" (or something very similar) and no useful info was returned. I also looked through the 3 scribus manuals I have here and none of them mention that vector graphics are highlighted in pink when selected. I was expecting something similar to the text boxes when they are selected (no shift in background color).
78
I have 21 line art anatomy graphics I created in Inkscape to import into my Scribus book project. None of these graphics were created using any colors; the lines are either all black or shades of gray (2 or 3 shades only). Background color is white or transparent (iirc I converted all to white but may have missed a few that may remain transparent).

I just imported graphic #1 and was surprised to see a light pink color filling the graphic. I assume this is a background color as my line drawing shows through it, but I suppose it could also be an overlay that allows the underlying graphic to show through. In the Properties dialogue box both the Line and Fill colors show as "None." When I choose the Fill icon, then choose "White" in the color options below, the letter identifyers in my graphic that will match the caption description below disappear, and here's the surprise: when I then go to "Edit > Undo set fill color" the letters reappear and the background becomes white (which is what I want).

> Any ideas as to why the pink background appears in the first place, why setting the Fill color removes my letter identifyers, and why Undoing setting the Fill color then gives me what should have been the correct background color upon importing? I'm stumped but would like to understand.

Attached is a section of the imported graphic with the pink background.

One final question: should I be concerned that despite being a vector file, it is fairly easy to see a pixelation effect on the vector lines? In Inkscape, these show as true vector lines with no pixelation no matter how much I enlarge the graphic.

I'm using the latest stable version 1.4.8, on a Linux machine with 8GB ram
79
General Discussion / Scribus immediately crashes
« Last post by thomasn on October 25, 2021, 11:54:04 am »
I have been using Scribus for years and it has always been great. I've had a bit of a break from the kind of tasks that require Scribus recently, so today was the first time trying to use it in a couple months.

Now, it immediately crashes with the message "Scribus crashes due to Signal #11".

Trying to start it from a terminal to get a bit more information, I get these messages leading up to the crash:
Code: [Select]
Warning: dynamic library '/usr/lib/osgPlugins-3.6.5/osgdb_gdal.so' exists, but an error occurred while trying to open it:
libgdal.so.29: cannot open shared object file: No such file or directory
Warning: dynamic library '/usr/lib/osgPlugins-3.6.5/osgdb_ogr.so' exists, but an error occurred while trying to open it:
libgdal.so.29: cannot open shared object file: No such file or directory
Warning: dynamic library '/usr/lib/osgPlugins-3.6.5/osgdb_vnc.so' exists, but an error occurred while trying to open it:
libvncclient.so.1: cannot open shared object file: No such file or directory
ReaderWriterTF::writeObject
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/lab.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/spot.png: File not found
pathForIcon: Unable to load icon /usr/share/scribus/icons/1_5_1/register.png: File not found
qt.gui.icc: Unsupported ICC profile class 70727472
QPngHandler: Failed to parse ICC profile
Scribus Crash
-------------
Scribus crashes due to Signal #11

This is using Scribus 1.5.7-6 on an up-to-date Arch Linux system.
Any ideas where I can go from here to troubleshoot this issue?
80
Scripts and Plugins / Re: Monthly Calendar script
« Last post by rafferty on October 25, 2021, 11:49:27 am »
Pages: 1 2 3 4 5 6 7 [8] 9 10