Recent posts

Scribus forums / Re: Missing letter
Last post by MZaske - March 24, 2023, 06:36:28 PM
So is this the place, where "old" list veterans can hang out and chat?

I came here today to find a solution and had to post my own question.

This forum will be very secure from spam, because even as a human being, I have trouble filling all the security stuff under my post. Seems I cannot even count the letters in Scribs...

Scribus is still muchly useful in our project. There are not many areas left, where Scribus cannot do what we need. Greetings.

Announcements and Forum Rules / Re: My first post: Identifyin...
Last post by MZaske - March 24, 2023, 06:14:31 PM
Thank you for completing your thread with the solution.

Please consider marking your question (the headline) with something like [solved]. That way it will be attractive to other users with a similar question. Seems only you can edit your original post.

I am new here again, after years on the old mailing list. I posted my own question today and I hope I can soon mark it [solved] too.
Tutorials, Tips and How-Tos / Need certain color in Item Too...
Last post by MZaske - March 24, 2023, 05:53:41 PM
I have a document, where I have to create many draw-out lines in a customer-pre-defined color.

So I go > Document Properties > Item Tools > Lines. And I set my Line-style, width etc. All that works fine, as normally.

BUT: I only get a very short list of Line Color options.

My question: How can I set any needed color in "Item Tools" > Lines > Line Color?

In the document under > Edit > Colors and Fills I have defined the customer's special color of choice and have given it a name. And it appears fine in all other menus, where I have to select a color. And I have chosen a large Color Set for my document. But whatever I try, under "Item Tools" the colors on offer are always this very short list.

I am missing a step, please help.
General Discussion / Re: How easy/hard is it to wor...
Last post by zacl - March 24, 2023, 11:29:28 AM
I think I have done what you want to do for fan translation of a game. I translate text in Gdrive calc. I made a templateScribus file with placeholder text in frame box (line number of the Gcalc sheet where text is located). A python code take the text with formatting (bold, italic, color) and replace it in the template.
I can autogenerate a pdf like that.
Beginner Talk / Re: Floating Palettes and Gnom...
Last post by Portreve - March 22, 2023, 02:04:17 AM
I have now reported this issue as a bug, and the report number is 16915.
Beginner Talk / Re: How do I dock the floating...
Last post by Portreve - March 21, 2023, 11:33:13 PM
Quote from: geoma on August 17, 2022, 02:29:01 AMThey simply won't dock.... could it be something to do with my WM? I am using swaywm...

Hey geoma...

I think I may have figured out the problem and how you can work around it.

If you are doing this in Gnome 3.x, then this is a Wayland issue. Here's how you can deal with it.

Log out, then when you go to log back in, log in and set the session type to be Gnome Xorg.

Go back into Scribus and fix everything up just the way you would like it.

Then, log back out and log in using Wayland. Don't mess with the palettes or they will undock and you won't be able to dock them again unless you go through the above procedure.

I've already notated this in a thread I just created today.
Beginner Talk / Re: Floating Palettes and Gnom...
Last post by Portreve - March 21, 2023, 11:29:45 PM

Ok, so after a kind suggestion from someone on the TuxDigital Discord group, here's what I've discovered.

If you are in a Wayland Gnome session, the aberrant behavior is exactly as I described above. However, if you log out, then log in in an session, the palettes work exactly as they should (i.e. they are dockable). And if you then log back in in a Wayland session, the docked palettes will remain docked and work just fine. But if you were to close one or grab and move it, then it will no longer be docked and cannot be re-docked unless you log in under an Xorg session first.

So, I am left with the inescapable conclusion that this is not a Gnome 3.x issue so much as it is a Wayland incompatibility.
Beginner Talk / Floating Palettes and Gnome 3....
Last post by Portreve - March 21, 2023, 11:07:46 PM
First, I want to cite an existing thread on this topic: How do I dock the floating palettes? 1.5.6 by farmerf.

Also, I'd like to point to another individual also having this same issue:

Quote from: geoma on August 17, 2022, 02:29:01 AMThey simply won't dock.... could it be something to do with my WM? I am using swaywm...

Here's what I have found. If you are using Cinnamon or KDE, and probably other DEs but I haven't tried them all out, there is no issue whatsoever getting Scribus to dock floating palettes. Just drag them to the right edge of the Scribus window and *poof!* they will dock. Keep dragging them over there and you'll have a series of tabs at the bottom so you can go directly to the palette in question.

But, in Gnome 3 (I've seen this behavior in at least the 3.4x series) it just won't work. The palettes do not dock, no matter what one does.

Is there any way for users to fix this, or is this some kind of desktop environment-related bug?
PDF Generation / Re: single Line after pdf expo...
Last post by PatJr - March 21, 2023, 12:37:07 AM
out put the inkscape file as a png?

I had a similar problem a while back, what I did was open a new inkscape document and then cut and paste the graphic to it. Dunno why it work then, must have been some element that I couldn't see in the original file.
PDF Generation / single Line after pdf export
Last post by rostgerradler - March 21, 2023, 12:27:56 AM
I have a problem with a single Line in a few files after pdf export.
The design starts with inkscape, save as *.svg.Then open a new file in Scribus, import the svg file, convert to CMYK, save as *.sla. All looks fine. After export the file as PDF/X-1a there is a single Line which i can not find in the svg or in the sla file.
I recognized the mistake after get 4 beachflags printed by a professionel service. Ok, i have to live with that, but i don't want to do this mistake again.
What could i do?
If the files are needed for help, there is no problem. My work is under CC-BY-SA, but there is a registered Logo in it.



Debian Bullseye
14 November 2020
Build ID: C--T-F-C1.16.0-64bit
Ghostscript-Version: 9.53.3