Scribus Forums

Scribus => General Discussion => Topic started by: glenm on January 17, 2021, 01:24:12 pm

Title: gaps around the pattern tiles
Post by: glenm on January 17, 2021, 01:24:12 pm
First, thanks to everyone who creates Scribus and all Linux software.
I recently upgraded to Mint Mate 20 which includes Scribus 1.5.5. Now when I open my files I created on Mint Mate 18.2 I have gaps around the pattern tiles.
When I export to an image the gaps show in the exported file.
If I click on the image preview quality it refreshes and the gaps are gone.
I have tried Gimp .pat files, png and plain svg created in Inkscape.
I tried using different sizes and resolutions for the pattern files.
Attached is a cropped part of an exported imaged.

Any ideas on what is causing this and a possible fix?
Title: Re: gaps around the pattern tiles
Post by: utnik on January 17, 2021, 02:14:58 pm
hi glenm

i miss your attachment.

utnik
Title: Re: gaps around the pattern tiles
Post by: glenm on January 18, 2021, 08:31:58 am
I had problems the first time I tried to post and forgot to add the attachment when I got it to work.
Here it is.
Title: Re: gaps around the pattern tiles
Post by: AdmFubar on January 18, 2021, 10:46:20 pm
We need a lil more info regarding what you are attempting to do. and how you are doing it.How are the tiles created?  What are you using them for?
Title: Re: gaps around the pattern tiles
Post by: glenm on January 19, 2021, 02:18:40 pm
I created shapes using shape tool and the freehand tool and I have filled them with patterns. I created the patterns in Gimp. I have tried .pat and .png files. The .pat files work perfectly in the old version Scribus in Mint Mate 18.2.
Now in Scribus 1.5.5 I have gaps around the tiles.
So I tried opening and saving the patterns as .svg using Inkscape.
Still have gaps.
These gaps show in exported images. The sample I uploaded was cut from an exported png.
If I hit the preview quality button it refreshes the drawing and the gaps go away. I don't even have to change the quality, just force a refresh at either high or normal.
I am using the same computer and hardware, just upgraded to Mint Mate 20. ASUS desktop with AMD A6-6400K, 4GB ram, NVIDIA GK208B with 2GB. I have tried the the Nvidia 390 driver and the Nouveau driver.
I have tried all 3 Marco settings.
Title: Re: gaps around the pattern tiles
Post by: glenm on January 19, 2021, 03:46:04 pm
So i have been experimenting more and created a new document with shapes and filled them with the same patterns.
It had gaps too.
So I enabled colour management and the gaps went away, even after saving and reopening the doc again.
I enabled colour management on a couple of my old files and noticed the settings were all Apple.
I changed the settings to sRGB v2.2 and ISO coated v2 300%.
And that fixed the problems so far.

Thanks for the help, Glen
Title: Re: gaps around the pattern tiles
Post by: AdmFubar on January 19, 2021, 10:41:21 pm
For whatever I said I'm glad it worked out. It did sound like the issue was related to how the shapes were created. Color space can play all sorts of havoc in this situation.