Recent posts

Beginner Talk / Re: Why use DPI (not ppi)? (im...
Last post by Nermander - Today at 11:03:42 AM
PPI would be the correct term, but for digital media the PPI equals the DPI. I am not aware of any digital format where a pixel is made up of several dots.
Beginner Talk / Why use DPI (not ppi)? (image ...
Last post by yichuang驿窗 - Today at 08:00:43 AM
The location labeled on the attached screenshot uses the DPI.
I looked at the wiki, and the WIKI also mentions that it should be DPI.
Why use DPI instead of PPI?

The screencapture is the Content Properties of image frame.
Linux / Re: Scribus 1.6.2 was not able...
Last post by licheng - Today at 06:39:15 AM
I recompile Python 3.12.4 myself with the "-fPIC" option and install it on Debian 12, then recompile Scribus 1.16.2 and it works fine.

jghali, thanks for the tip, I really appreciate it.
PDF Generation / Re: Signal #11 error on PDF ex...
Last post by buzdam - June 19, 2024, 06:44:04 AM
I'm also facing a similar problem. Let me know if you have fixed this error.
PDF Generation / Re: Pages have a white line
Last post by pickaxen - June 19, 2024, 06:35:36 AM
Thanks for your solutions! I have fixed it.
Linux / Re: Scribus 1.6.2 was not able...
Last post by licheng - June 19, 2024, 04:44:05 AM
Thanks a.l.e and jghali, you're right.

I have a self compiled version of Python (3.12.3), everything works as expected when I remove it.

I'm a long time Scribus user, I use it to make photo books, postcards, posters and zines. I'm used to compiling Scribus myself just to make sure I can use Scribus no matter what OS I have.

Thank you for your great help.
Linux / Re: Scribus 1.6.2 was not able...
Last post by jghali - June 18, 2024, 03:17:08 PM
I installed a Debian 12 virtual machines yesterday and managed to build Scribus 1.6.2 on it successfully. But Debian 12 comes with Python 11, not 12, so I also suspect a custom Python, presumably built without -fPIC option.
Linux / Re: Scribus 1.6.2 was not able...
Last post by a.l.e - June 18, 2024, 10:36:39 AM
sometimes, i wonder if people have lost the skill to copy paste text and only can do screenshots : - )

anyway, for the little that is visible in the screenshot, i would say that this is not a "typical" error due to missing dependencies.

i googled the error "against hidden symbol pkgcontext" and this is what i've found:

since you're compiling a release version of scribus, instead of using a binary (packaged by your distribution or in the appimage), i wonder if you also have a self compiled python, with incompatible flags (as the stackoverflow answer hints).

another source for the issue, could be that you're mixing old and new compiled files, while having had an update of system installed libraries...
but you seem to use a "scribus-1.6.2" which seems to hint to a newly created directory.
PDF Generation / Re: Best pdf output for Family...
Last post by kiwi_steve - June 18, 2024, 02:44:52 AM
Can I just confirm, you are bringing the charts and the text in as an image?  Are you able to separate the text away from the chart, then add the text in text boxes in Scribus?

Also, as sersha mentioned - you can right-click images and choose Preview Settings, then Full Resolution - it slows down the editor if you leave them all in full resolution - so I use that option to see what the images will look like when printed, then switch it back to normal resolution...

Exporting to PDF should also have everything in full resolution unless you have compression turned on.

Cheers, Steve
MacOS / Re: Preferences gray out for 1...
Last post by reckoz - June 17, 2024, 04:25:44 PM
Quote from: MrB on June 12, 2024, 08:58:16 PMI'd suggest trying to run Scribus in English as a test. You can do that from the command line eg "scribus -l en".

Or in the prefs150.xml (example name), check for similar text:
                <context name="user_preferences">
                        <attribute key="gui_language" value="en_US"/>

Having ensured Scribus is closed, change the value there as above, and reopen Scribus.

Thanks. The issue is solved! The ' Preferences ' becomes clickable after changing the GUI language to English. The problem may arise due to the missing translation of this item in the new version.