Scribus Forums

Scribus => Beginner Talk => Topic started by: Lothar on April 09, 2016, 05:05:10 am

Title: Cannot get lines to print
Post by: Lothar on April 09, 2016, 05:05:10 am
I cannot get lines to print. Rectangles and free-hand lines print fine. I have tried setting the stroke colour to black and have also tried defining a line style, all to no avail.
Title: Re: Cannot get lines to print
Post by: utnik on April 09, 2016, 09:06:40 am
hi lothar

could you share your .sla file which shows the problem?

Title: Re: Cannot get lines to print
Post by: Lothar on April 09, 2016, 11:23:18 am
Hi utnik

Please see attached. I drew a test line below the text

Thanks, Lothar
Title: Re: Cannot get lines to print
Post by: GarryP on April 09, 2016, 11:38:14 am
The file says that you're using version 1.5.1 which is still classed as a developmental version of Scribus. Have you had the same trouble when using the latest stable version?

And just as a bit of extra info', are you printing directly from Scribus or from an exported PDF? (Printing directly from Scribus has been reported as a bit "patchy" by some users.)
Title: Re: Cannot get lines to print
Post by: GarryP on April 09, 2016, 11:56:18 am
A quick note for people using "non-stable" versions of Scribus

When reporting problems with a developmental version of Scribus you need to report the full spec of the version you're using. You can get this info' from the "About Scribus" dialog (from the Help menu). Just copy and paste the text under the splash screen graphic. For example, the stable version I'm using says "Scribus Version 1.4.6 03 January 2016 Build ID: C-*-T-*-C1.8.6-Windows Using Ghostscript version 9.18". (Developmental versions usually have extra info' reported to aid problem solving.)

The developmental version of Scribus changes from day to day so the version you have may contain some inadvertant bugs that could have been fixed since you got the code. If in doubt, grab the latest version of the code and recompile before reporting an issue (assuming that it's still an issue of course).
Title: Re: Cannot get lines to print
Post by: Lothar on April 09, 2016, 12:54:52 pm
I originally had the problem in
Scribus Version 1.4.6
03 January 2016
Build ID: C-*-T-*-C1.8.6-Windows-64bit
Using Ghostscript version 9.19

I moved to 1.5.1 because I wanted to use tables, but am willing to go back if that is recommended.

Scribus Version 1.5.1
14 February 2016
Build ID: C-*-T-*-C1.14.6-Windows-64bit
Using Ghostscript version 9.19
Title: Re: Cannot get lines to print
Post by: Lothar on April 09, 2016, 01:04:27 pm
Sorry, to answer all the questions:

Earlier in the week I tried both Print Preview and printing to a real printer.

When utnik asked for my .sla file, I had already discarded the file with the problem, so I made a new example. When I checked it in Print Preview, it did not have the line. However, checking it now, it's working! As far as I know I did nothing other than moving the line to my image layer and then back to my text layer.


Regards, Lothar
Title: Re: Cannot get lines to print
Post by: GarryP on April 09, 2016, 02:53:23 pm
Generally I would recommend only printing from an exported PDF. Even if you're not going to distribute your document you can use the PDF as a final "proof" before printing. Think of it as getting a second opinion, and if you do come to distribute your document you'll already know that it's okay.

Also, unless you need one of the special functions of the Print Preview you might want to look at using the Preview Mode instead (use the eye icon near the bottom right of the main window). Personally I never use either Print or Print Preview in Scribus.

As for why the line goes missing (and comes back), that's a bit of a head scratcher. Sometimes it can happen if "disable export" (Properties Palette / X,Y,Z / Printer Icon) has been accidentally pressed. A similar thing can happen to whole layers if the checkbox for that layer under the "eye" icon in the Layers Manager has been unchecked.

Unfortunately there's no way of finding out which objects aren't exportable without checking each one. And there is no "globally make everything exportable" function as a quick fix when you don't know what could have happened.

(One way of making a line go missing, of course, is to give it the same colour as the background or set its transparency to 100%, but you're not doing that. Or you can set the Opacity of the layer to 0% but that's probably not what's going on either.)

Maybe someone else has a better idea of what's going on (especially if they can open your file and reproduce the problem). It could be something very simple that I'm missing.

As for which version to use, it's normally recommended that people use the latest stable version unless they really need some of the new features. Personally I'd get the document looking as correct as I could using the stable version (with placeholders where necessary), then open it in the new version - saving under a new name so the previous version doesn't get overwritten - and continuing from there. This all depends on your personal level of risk vs. reward though. Many people use 1.5.1 on a day-to-day basis without any problem so it's an individual choice. (Your 1.5.1 installation is nearly two months old so it might be worth updating to get the latest code anyway.)
Title: Re: Cannot get lines to print
Post by: Lothar on April 27, 2016, 03:49:29 pm
Thanks for the good advice. I have gone back to 1.4.6 and started again from scratch. The problem with missing lines has not occurred again.

I am using styles for everything, and am happy with the results.

I am writing a technical manual. Just wondering - if I need to add a paragraph in a text frame, are there any tools to push subsequent image frames along by the required amount?

Thanks again, Lothar.
Title: Re: Cannot get lines to print
Post by: GarryP on April 27, 2016, 04:30:33 pm
You're welcome Lothar. Glad to be of some assistance.

In answer to your question: It sounds like you want to add some text into a frame and then for an image frame to automatically move to accommodate the change.

Unfortunately there is no way for changes to the text to affect the placement of other objects, if that's what you mean. There's no link between text/frame sizes or positions so it can't be done, except manually. (Personally I wouldn't trust the software - any software, not just Scribus - to move it where I wanted it to anyway.)

(This isn't quite true for "inline images" but I'd avoid using them altogether as you can get into a real mess. If you don't know about inline images then please try and forget that you heard about them.)