Scribus Forums

Scribus => Installation and Setup => Linux => Topic started by: amnesix on November 16, 2011, 03:34:06 pm

Title: Debian Repository tu use Scribus "Trunk" (1.5) sous LMDE (Mint Debian Edition) ?
Post by: amnesix on November 16, 2011, 03:34:06 pm
Hi there,

I was a happy user of both Ubuntu and Scribus "trunk" (1.5x), until ubuntu decided to force Unity in my throat.

I decided to move to Mint (Debian Edition 64bits), and fron this side of life, I'm happy.

But then it comes to Scribus, I'm slightly less happy : I can't find any repository that allows me to install Scribus "trunk". And this is sad, because I have a few "open" projects which include .sla Scribus files which I can't open anymore...

Does anyone how I can install Scribus *without* compiling involved ?

Thank you in advance for any answer !

--
amnesix
Berlin
Germany
Title: Re: Debian Repository tu use Scribus "Trunk" (1.5) sous LMDE (Mint Debian Edition) ?
Post by: Meho R. on November 16, 2011, 07:21:27 pm
On Ubuntu, did you install Scribus from a PPA? Couldn't you use .deb files provided by that repo with Mint too? E.g., I've found this PPA (https://launchpad.net/~scribus/+archive/ppa/+packages), you can try adding it to your sources list or simply download .deb files and try to install them (try natty and maverick; no 64-bit version for lucid, and precise isn't even in alpha stage yet).
Title: Re: Debian Repository tu use Scribus "Trunk" (1.5) sous LMDE (Mint Debian Edition) ?
Post by: amnesix on November 16, 2011, 08:29:46 pm
As far as I know. LMDE will not support PPAs. I tried to install the packages individually, but I get some "unsatisfiable dependencies"... Too bad ! :)

Title: Re: Debian Repository tu use Scribus "Trunk" (1.5) sous LMDE (Mint Debian Edition) ?
Post by: Meho R. on November 16, 2011, 09:42:14 pm
True, but PPAs are repos like every others. So, in case those unmet deps are poppler and libpodofo, you can add PPA manually and see if it helps. Add to /etc/apt/sources.list:
Code: [Select]
deb http://ppa.launchpad.net/scribus/ppa/ubuntu natty main
deb-src http://ppa.launchpad.net/scribus/ppa/ubuntu natty main
Add key and refresh repos:
Code: [Select]
su
apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 64B6EE15
apt-get update
Try installing scribus-ng from Synaptic.
Title: Re: Debian Repository tu use Scribus "Trunk" (1.5) sous LMDE (Mint Debian Edition) ?
Post by: amnesix on November 17, 2011, 12:23:15 am
NIfty idea... but scribus was declared by the system as "broken", and it won't install... :(

Anyway, thank you for the time you take to answer me !