Scribus and Gimp

Previous topic - Next topic



i have downloaded The Gimp version here : I wanted this version because it's more completed.
it's not compatible with scribes. Right?

Can-you help me please ?



hi barnabu

what exatly is not compatible?
i usually work with scribus (at the moment 1.4.2) and for pixel images with gimp 2.8.4 – on snow leopard...

what doesn't work for you?




thank you to answer me.
When i click on the right button (mouse) and click on edit image, i have an error : gimp is not installed.
However, it's installed. Is it because it's an another version of Gimp ?



barnabu, you need to tell Scribus where Gimp is installed.

Select menu item "Scribus -> Preferences..." then select "External Tools" from the list down the left-hand side of the dialog.
In a box titled "Image Processing Tool" the "Name of Executable" should be /Applications/ (unless you've installed Gimp somewhere different). Then "OK" the dialog.

You should then, in theory, be able to use the "Edit Image..." function to edit the image in Gimp.

However, I've noticed that, with Scribus 1.4.2 and Gimp on OSX 2.8.2 (and 2.8.4), the image doesn't "get through" to Gimp for some reason. Gimp loads but the image isn't loaded into it - I just get an "empty" window. And a subsequent use of the "Edit Image..." function displays a warning that the program is already running.

I've no idea whether this is a problem with Scribus or Gimp or both or whether my set-up is wrong but there are other posts on the forum where people have had mixed experiences. It seems like it works for some people but not for others.

Since I've had the same problem with different versions of both applications I've got into the habit of not using the "Edit Image..." function at all and I just go into Gimp "manually". Scribus automatically picks up any changes anyway so there's no need to manually update the Scribus document.

I hope someone else can explain the actual problem as I'd be worried that some people might think that Scribus is broken in some way and stop using it, which would be a shame.


Thank you for your answer.

it's OK.

but, i can't help you for your problem.
If i have the same problem that you i will say you.

Bye and thanks again



For your problem, you should test to clean your mac with onyx or an another software.
I have had problems with inkscape, with the interpolation function which didn't work. i have used onyx and interpolation worked. I don't know why, but you should try it.



I have the same empty image problem with Elements 11 and Scribus 1.4.2 on Windows7 Professional. I tried with Gimp and that seemed ok, but I don't use Gimp. I'm sure its very good but Elements does everything I want and I know how to use it (at least somewhat).


Thanks for the suggestion of Onyx barnabu.

After installing, I tried deleting the Application caches with no effect, then the System caches, again with no effect. I'm not very tech-savy with Macs so the other things Onyx can do look very scary.

I might try some other things at some point if I drum up the courage but, unless someone can pinpoint the exact thing I should do, I'll probably just continue to do what I was doing before.

If I figure something out I hope I'll remember this post so I can add a solution.

P.S. I tried changing the default application for various image formats to Gimp (rather than Preview) on the tiny chance that would help, but no cigar.