[SOLVED] Page Numbers Don't Appear [Urgent]

Previous topic - Next topic


Hi all,

I'm in need of urgent assistance.

I have a 100+ page memoir ready for print and the last step is to add page numbers, yet they won't appear. I have read every thread I can find about adding page numbers, and despite following directions and scouring my settings, I cannot get automated page numbers to appear in my project. This problem persists regardless of the text box size; it's not simply being cut off. I am able to add page numbers on other documents, but not this specific one.

  • To add a page number, I create a text box, double click to activate the text cursor, then go to Insert -> Character -> Page Number. However, the page number does not appear. I've ensured that the text color is black.
  • All other elements in the Character tab insert and display as intended (e.g. trademark symbol).
  • When adding page numbers to a master page, the correct (#) box appears in the master page. Upon returning to the document and applying the master page to any given page, the page number does not appear. All other master page functions work as intended (e.g. I can add a text box with random text, and it displays correctly). The text frame is also there, and plenty large.
  • I've also tried using the "Sections" tab to set up numbering to no avail.

I've read official forum posts with directions, troubleshooting posts, and scoured through my settings to get to the root of this issue.
  • Under Preferences/Document Setup -> Tools, my "Text Color" and "Text Stroke" are both black, at 100% shading.
  • I've tried importing master pages from a document in which page numbering works, but the page numbers don't show up.
  • I only have one layer for this project, which is visible.

There has to be some setting toggled that I'm missing, but I can't find it. Or it's a bug. Any insight is SINCERELY appreciated; I'm on a tight deadline and this is driving me mad.

Thank you,


dunno, maybe make a sample file by deleting 95 of the pages, replace your text with some lorem ipsum and save that as 'numbering_problem.sla' and post it up here?



Great idea. Here's a stripped, 5-page segment of my project. Thank you in advance!


Loaded your test document and poked around. Checked on the master pages, and found the page numbering text. Selected the text frame and opened it up in the story editor. The # was in red, that usually means some non printing control character. So I erased it and replaced it with another #, works just fine.

Select your master page and the page number text, open in the story editor and see what it looks like.
Now you are using a much older version of scribus, this might be why the there is an issue. Update to 1.6.1 as soon as you can.
Using Scribus 1.6.1, openSUSE 15.6
Advanced hobbyist


Hi AdmFubar,

I downloaded 1.6.1 and tried your suggestions. Still unable to produce page numbers. Replacing the red "#" with a regular "#" simply reads as a hashtag outside of the master page, not an automated page number. I've tried the same process on regular pages with a text box.

Regardless, thanks for your time.


no idea what that option does, but:

you need to go to the file > document settings > sections and check the box under shown...

(how did i find that? in your document the page number does not show here either. but in a new document they are there. and then i looked around for differences between the two documents...)


SOLVED!!! a.l.e you're a legend. I hoped you'd see this post.

I actually toggled that setting multiple times, but every time I did, it would cause every page in my project except for the one I was currently on to disappear — which prompted me to panic and discard the changes. This time it worked perfectly.

Thank you so much! I spent 4 or more hours trying to troubleshoot this.