Problems with POPPLER_LIBRARY-NOTFOUND when compiling svn on Ubuntu 12.04

Previous topic - Next topic


When compiling on a fresh Ubuntu 12.04 64bit install I get stuck with the following missign Path info

-- Found poppler
-- Found poppler libs: POPPLER_LIBRARY-NOTFOUND
-- Found poppler includes: /usr/include/poppler

cmake aborts later with the following error:

CMake Error: The following variables are used in this project, but they are set to NOTFOUND.
Please set them or make sure they are set and tested correctly in the CMake files:
    linked by target "importpdf" in directory /home/markus/src/Scribus/scribus/plugins/import/pdf

-- Configuring incomplete, errors occurred!

I have installed about anything that has to do with poppler and poppler devel but still get that error.

Any ideas?


I had the same problem. Solved only by building poppler in a seperate directory, exporting paths appropriate paths and then re-running cmake

I can provide more detailed steps if you haven't solved the problem and still eant to build it.

Pretty sure it is an Ubuntu packaging defect