All my document windows open off screen

Previous topic - Next topic

jrasicmark

I'm using Scribus Portable on a thumb drive. The properties and align palettes are visible, but I can see the main document window opens on the far right, off the monitor screen.
I Googled ways of moving the window back using Windows shortcut keys, but they didn't work. I also tried using the various options for arranging windows using the taskbar, but they only rearranged the windows that are already visible on screen.
Since it's portable, I had been using the app on a PC that is set up to use two monitors as well as my own laptop at home (which is only one monitor), so I thought it had something to do with that. I thought I would be able to open it on the PC with 2 monitors and just move the window to the default monitor so I would see it on my home laptop. But the document window won't even show up with 2 monitors. It still opens off-screen on the right side of the right monitor.
Is there a way to fix this, either from Scribus or from Windows? I saw on another thread, someone suggested editing the Scribus preferences in Notpad and it gave the address on where to find the Scribus preferences in Windows. But since I'm using Scribus Portable, the address isn't the same. I thought I found the Scribus preferences file on the thumb drive, but when I opened it I couldn't find the line it said to look for (I think it said to look for a line containing "<MAINWINDOW" or something similar, but it wasn't there at all). Maybe it's in another folder on the thumb drive, I don't know.
The only other option I can think of is, the thumb drive is close to being full now. So is it possible that this is a memory issue? That maybe Scribus can't find enough memory from the empty space on the thumb drive to open documents properly?
If so, how can I fix it? Move it to a bigger portable external drive?
Any ideas?
Thanks.

jrasicmark

I just tried re-installing Scribus Portable on the same thumb drive, thinking that might fix it, but the same problem persists.

PatJr

can you put it on the local HD ?
is there a way to delete or rename the users config directory for it?
I don't use Windows but on lunix it's something like /hoem/USER/.config/scribus for a local install
the flatpak install I use has a path for the config files as
 /home/USER/.var/app/net.scribus.Scribus/config/scribus/


AdmFubar

PatJr's suggest would be the first to try. It is most likely an issue with your config file. rename it without scribus running and then start scribus and let it rebuild the config file and see if that sures the issue.
Using Scribus 1.5.8 + 1.6.1, openSUSE 15.5
Advanced hobbyist

MrB

scribus15.rc will have a line line:
 <MainWindow ScreenNumber="1" XPosition="349" Maximized="0" Width="1131" YPosition="95" Height="845"/>

Edit XPosition and YPosition.

jrasicmark

 ;D Thanks so much! I did a search on my thumb drive for .rc files and found 2 called Scribus140. I had to change the main window position in both, but once I did that, the main window is back! WHEW! What a relief!
Thanks to all of you!

johngriswold

I have the same problem on Windows. Where is the equivalent information for Windows? Please?
Thanks.

AdmFubar

Where your config file for scribus is located will depend on what version of windows you are using,
I dont know where the scribus config files in windows are  located offhand. I'm sure another user here will be able to help out.
Anyone? :)
Using Scribus 1.5.8 + 1.6.1, openSUSE 15.5
Advanced hobbyist

a.l.e

i'm no windows user but my notes say:

<username>\AppData\Roaming\Scribus
https://github.com/aoloe/scribus-manual-windows/blob/master/NOTES.md#where-are-the-preference-files

if somebody has more information, please share it...

johngriswold

Perfect. In scribus140.rc the MAINWINDOW XPOS and YPOS values were set to "0" and I found the screen again.

Thank you.