Esportare PDF (Stampare con SumatraPDF)

Previous topic - Next topic

vittap

Buongiorno e grazie per avermi accolto nel forum. Problema: una pagina Scribus 1.5 viene stampata dal programma bene e con le giuste proporzioni. La stessa pagina esportata in PDF e stampata risulta con il contenuto leggermente rimpicciolito. Perchè? Devo mantenere  anche nel file PDF le proporzioni originali e non so come fare. Grazie!

a.l.e

Non ci dai molte informazioni...

Ma dal poco che descrivi, direi che quando stampi il PDF, hai dimenticato di cambiare i setting e forzare il programma a stampare al 100%.

La modalità precisa per cambiare le proporzioni di stampa, dipendono dal programma che utilizzi per visualizzare il PDF.

Un ricerca per "print 100% pdf" da diversi risultati che possono esserti d'aiuto.

Se non lo trovi o se la causa è un'altra prova a darci più dettagli e, forse, qualcuno ha altri consigli.

Ciao
a.l.e

vittap

Uso Sumatra per visualizzare e stampare PDF. In questo programma non sembra esserci la possibilità di settare la stampa al 100% e la stampante (Brother DCP-L2550 DN) è settata per stampare senza ridimensionare.
Proverò a importare il PDF in un altro programma e da li stampare. Vi farò sapere.
Per ora, Grazie!!!

AdmFubar

Controlla le opzioni di sanguinamento dei documenti. Nella finestra di esportazione PDF, nella scheda Pre-Press, assicurarsi che le spurghe di utilizzo del documento siano controllate o, che le spurghi superiore, inferiore, sinistra e destra siano impostate su zero. Questo potrebbe essere il problema.




check your documents bleed options. In the pdf export window, in the pre-press tab , make sure the use document bleeds is checked, or, that the top, bottom, left and right bleeds are set to zero.

This may be the issue.
Using Scribus 1.5.8 + 1.6.1, openSUSE 15.5
Advanced hobbyist

vittap

Si! nella cartella Pre-Stampa della finestra esportazione PDF: tutti i margini al vivo del documento devono essere impostati a 0. Così viene prodotto un PDF con aspetto uguale al file origine di Scribus.
Grazie!!!!!
 :D

Nermander

I won't use google translate for the response, but a capable PDF viewer should be able to honor the trim box in the PDF.


https://www.pdf2go.com/blog/what-are-pdf-boxes

vittap


vittap

Desidero condividere la soluzione del problema e quanto ho imparato.
In File/Impostazioni documento, nella cartella "Margini & Pagina al vivo" i valori di "Pagina al vivo" devono essere tutti e quattro impostati a 0 e nella finestra di esportazione "Salva come PDF" nella cartella "Pre-Stampa" bisogna attivare la casella "Usa pagina al vivo del documento" per ottenere un PDF perfettamente uguale al file .SLA.
Per rendere definitiva questa impostazione: File/Preferenze/Esportazione PDF/Pre-stampa/Impostazioni pagine al vivo = 0
Ringrazio anche qui Vect del forum Inkscape/Scribus, gentile e competente, e ringrazio ancora tutti voi che mi avete aiutato! :-* 

a.l.e

salve vittapp,

contento che abbia funzionato.

ma non è la soluzione più semplice o generalmente valida.

se stampi su una stampante da ufficio, il tuo visualizzatore di Pdf dovrebbe permetterti di stampare al 100%. E ciò è tutto di cui hai bisogno.

una breve ricerca su internet mi da quest'immagine per acrobat reader:

100-per-cent.png

se queste sono le opzioni, ti tocca scegliere "none".

that's all folks : - )

vittap

Grazie per il suggerimento che terrò presente. Per ora uso come gestore dei PDF il programma Sumatra che non sembra offrire questa possibilità e per diversi motivi non credo che userò Acrobat Reader.
Grazie comunque!  ;)

a.l.e

siccome sumatra non esiste per linux non posso provare...

e non riesco a trovare degli screenshot del dialogo di stampa.

ma secondo la documentazione ufficiale, la stampa via riga di comando permette di definire

noscale, shrink and fit
https://www.sumatrapdfreader.org/docs/Command-line-arguments#printing-options


altrove,

https://www.sumatrapdfreader.org/docs/Advanced-options-settings

mi fa pensare che forse Settings / Advanced options... permette di definire lo "scaling"

PrinterDefaults [
    default value for scaling (shrink, fit, none)
    PrintScale = shrink
]

buona caccia al tesoro!

Nermander

If you don't want to use Acrobat, maybe try the free version of Foxit (we used to have Foxit at work before).

At least it is clear to me that the issue here is not Scribus.

vittap

#12
Quote from: Nermander on November 05, 2023, 11:50:33 AMIf you don't want to use Acrobat, maybe try the free version of Foxit (we used to have Foxit at work before).

At least it is clear to me that the issue here is not Scribus.
Proverò Foxit nella versione free.
Scribus era all'origine del mio problema perchè con i settaggi nelle "Impostazioni documento/Margini & Pagina al vivo" impostati non a zero ma a un valore positivo (io usavo 10) il programma produce un PDF leggermente più piccolo rispetto all'originale SLA. E' giusto che sia così e probabilmente si può ottenere una stampa non ridimensionata tramite il programma di stampa PDF (forse anche con Sumatra, secondo le indicazioni di a.l.e come puoi leggere sopra). In ogni modo basta chiedere a Scribus di usare i margini della pagina al vivo impostati a 0. Grazie per i suggerimenti!

vittap

Quote from: a.l.e on November 05, 2023, 09:05:46 AMsiccome sumatra non esiste per linux non posso provare...

e non riesco a trovare degli screenshot del dialogo di stampa.

ma secondo la documentazione ufficiale, la stampa via riga di comando permette di definire

noscale, shrink and fit
https://www.sumatrapdfreader.org/docs/Command-line-arguments#printing-options


altrove,

https://www.sumatrapdfreader.org/docs/Advanced-options-settings

mi fa pensare che forse Settings / Advanced options... permette di definire lo "scaling"

PrinterDefaults [
    default value for scaling (shrink, fit, none)
    PrintScale = shrink
]

buona caccia al tesoro!
Grazie, davvero andrò a caccia, adesso più che altro per curiosità e malgrado mastichi a fatica l'inglese