Adding fonts to the LaTeX editor

Previous topic - Next topic


I have tried to discover (via Wiki, help, etc) but cannot find the method for adding Fonts to the list within the Scribus built-in LaTeX editor. The drop-down menu there says, "Fonts only work when installed on your computer!" But the fonts ARE there on my computer, and my PATH allows them to be discovered (every other program on my platform finds the fonts I have installed).


this is way over my head
I did try it and my version said
OTF fonts with math support


I did have it set to XeLaTeX


Are the fonts you are trying to use actually installed in the system fonts directory, or are they in separate directory?

Dont know if this will help or not, but have a look here.
Using Scribus 1.6.1, openSUSE 15.5
Advanced hobbyist


Hmm. I don't think the Overleaf article suits this situation. If you using Xelatex or Lualatex, the system has (or, should have!) access to the package Fontspec, and so it should be able to incorporate any of the TTF or OTF fonts that can be found on my platform. But I cannot see any way to specify a path for that Scribus latex-font interface, and it seems to me that it isn't using the $PATH available to Scribus.
To get to the bottom of this, I think that somebody who has created the code behind this feature needs to chime-in on this discussion. Feel free to forward this to any Scribus code gurus out there!


This is an update.
I have discovered that, if I use the "external editor" option I can use the fonts installed on my computer (other than in the TexLive distro folders), and can make use of the ``fontspec`` package. I'd still like to figure out, or be guided through, the way to expand the fonts available without having to go to the external editor.