Scribus crashing when I try to add text link

Previous topic - Next topic


I'm not sure this is really a layout issue, but I don't know where to put my question.

Scribus has started crashing whenever I try to add a link to text on Master Pages. I create the text, then click the "Insert Link Annotation" button and click and drag to create the box where I want the link, but when I double click that new box to add the link information, Scribus immediately shuts down without saving - no error, it just closes. I've done some experimenting and it seems to work when I add links to a normal page, but crashes when I'm trying to add links to Master Pages. (I'm working on a new newsletter template, so there are links that are always the same.)

I'm using Scribus 1.4.8 on a laptop running Windows 11. I reinstalled Scribus 1.4.8 and updated my Ghostscript (no idea if that could possibly help, but I did it anyway...) to 10.01.1. I also tried installing Scribus 1.5.8 and using that, but the same thing happened.

I've been using Scribus for a while and never had this problem before. Nothing has changed in my system, so I'm not sure what to do! Help!



is this the little shoes thing?
I tried it and it seemed to work but maybe I'm not clicking on the right thing.
Is it a link, an external link, or a web link ?


Yes, it's the little shoes button. It's an external link, but it crashes before I can even choose that. It's only happening if I try to use that feature on a Master page.


I tried it again
seemed to work

I using 1.5.8 from a on fedora 36

made a new document
then Edit>Master Pages
put a text box and typed "blah blah blah blah" into it
clicked on the little shoes and drug a box around the two middle "blah blah"
then double clicked the link frame and the menu for the options popped up
picked External Link and set it to some jpg I have in that directory
then clicked the "End Edit" for the master pages
seemed to work but I didn't export the document and try the pdf

let me know if you have different steeps and I'll try it again.


Hm... those are basically the same steps that I always use. I just tried it on a new file and it worked. I guess that the newsletter file I have been working on is corrupted somehow. Well, that's a bummer, I guess I have to start my newsletter template over again.
Thank you for your help!