Glitch in story editor with mouse cursor

Previous topic - Next topic


Hello, fellow Scribus users. I love Scribus and have been using it for the typesetting fork of my editing business for over a year now. But there's been a recurring annoyance that I wanted to ask you long-time users about. When I open the story editor to load text or doing anything related, if I move my mouse cursor outside the story editor window, and then back in again, everything below where I was working inside the story editor glitches and disappears (there's blank white space in the editor, but not the text frame itself).

I have used versions 1.5.5,, and also 1.5.8, and it happens in all of these. I try not to move my cursor outside the story editor box when I open it, but it happens sometimes, and I have to close it out and reopen it again. It's frustrating. Does this occur for any of you? If so, is it an unavoidable quirk of Scribus or has this been addressed before by the development team and being worked on?
I hope I made sense in describing my issue. Thank you for taking the time to help me.


hi lone mesquite

i just played with the story editor on a text heavy document in scribus 1.5.8 and 1.7.0.svn on mac os.
after changing something in the story editor i run with the mouse pointer across the open scribus document, did some manipulations in another application and went back to scribus and the story editor. i wasn't able to trigger your issue.

i recommend two things:

  • file a bug report.
  • don't use the story editor for standard tasks. in the last couple of years (maybe sice scribus 1.4 or a little bit later) i didn't use it any more. it's much more intuitive to work in the text frame with the 'text properties'...


This might be more of  an OS issue. Sound like the screen isnt being refreshed correctly. It may be limited to Scribus, but there might be other programs that exhibit a similar glitch.
Using Scribus 1.6.1, openSUSE 15.6
Advanced hobbyist


Thank you, utnik and AdmFubar, for your kind replies and for trying to replicate my issue. I realized about 30 seconds after I hit Post that I forgot to mention that I'm on Linux Mint 20. It could very well be an OS issue which I will have to experiment with later.

I'd love to know if anyone else out there using Linux Mint is exhibiting this bug. Or am I the only one?  ;)
Thanks again.