Scribus > General Discussion

Problem with pasting spreadsheet with special characters

(1/1)

oldvic:
Hi. I'm pretty new to Scribus and really liking it. However there's one problem that hopefully someone can help me with. I'm trying to copy several spreadsheets (.ods files) into my Scribus document. They copy and paste just fine apart from one issue. All the spreadsheets contain the £ (GBP) symbol. In the Scribus document, these don't show as the GBP symbol, but rather as a capital A with a caret over the top. Similarly, the copyright symbol also shows as a capital A with a caret. But the $ (dollar) symbol pastes correctly.

As a test, I created a simple text document with all the special symbols from my keyboard and copied and pasted it into a Scribus text frame. That worked fine -- all the special symbols showed correctly. So the problem only arises with copy and paste of an .ods spreadsheet.

I've searched for some sort of encoding option or anything else that might make the GBP symbol paste correctly. But no luck. So any advice that anyone might be able to offer would be much appreciated. Thanks.

AdmFubar:
You need to use a font that supports those characters. What is the font that libreOffice uses? you will need to use that font in your Scribus document.

Nermander:
The ods file does not use the correct unicode symbols for those missing symbols, it uses substitute fonts where the symbols are using character codes that really belong to other symbols.

I would have a look at if it is possible to use search and replace in the ods file to replace the incorrect characters with correct unicode characters (copy them from the text document?).

Navigation

[0] Message Index

Go to full version