Scribusoid

Author Topic: Changing the default path to fonts  (Read 377 times)

nanni

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Changing the default path to fonts
« on: July 21, 2022, 02:43:54 pm »
Hi,

is there a way of telling Scribus to use a specific folder with font files? I don't mean to add additional font paths, but just the opposite: to have Scribus find only a specified folder containing a limited selection of fonts.

Thank you.

AdmFubar

  • Full Member
  • ***
  • Posts: 194
  • Karma: 2
  • Scribus User and Abuser
Re: Changing the default path to fonts
« Reply #1 on: July 21, 2022, 09:21:29 pm »
There isnt an option like that. However you may find this workaround suitable. In the preferences/fonts the first tab is Available Fonts. There is a check box for each font. You can select what fonts want to see in the when selecting them from the drop down.
While tedious to use if you have a lot of fonts it might work for your situation.
« Last Edit: July 22, 2022, 12:39:38 pm by a.l.e »
Using Scribus 1.5.8 openSUSE 15.4
Advanced hobbyist

nanni

  • Newbie
  • *
  • Posts: 9
  • Karma: 0
  • Scribus User
Re: Changing the default path to fonts
« Reply #2 on: July 23, 2022, 03:56:44 am »
Hi, thank you.

I did find a workaround. In Preferences>Fonts>Available Fonts I unticked each font, which is outside of my desired font folder. After restarting Scribus, only the fonts in the folder I do want to use were available.

matrudon20

  • Newbie
  • *
  • Posts: 1
  • Karma: 0
  • Scribus User
Re: Changing the default path to fonts
« Reply #3 on: November 12, 2022, 08:22:46 am »
I've tried this with Exocet (diablo font) and it didn't work, there seems to be some restriction, like having an actual SmallCaps variant, or something... If someone can make it work, I'm interested.


AdmFubar

  • Full Member
  • ***
  • Posts: 194
  • Karma: 2
  • Scribus User and Abuser
Re: Changing the default path to fonts
« Reply #4 on: November 12, 2022, 11:10:35 pm »
I've tried this with Exocet (diablo font) and it didn't work, there seems to be some restriction, like having an actual SmallCaps variant, or something... If someone can make it work, I'm interested.
I think we are missing some info here. What isn't working exactly?  as your request doesn't seem to match what we are trying to solve here.
Using Scribus 1.5.8 openSUSE 15.4
Advanced hobbyist