Author Topic: Fatal error - cannot open file  (Read 907 times)

core

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
  • Scribus User
Fatal error - cannot open file
« on: January 18, 2022, 12:32:56 pm »
Hi Guys,

I created a small booklet in Scribus on my Linux computer which is down at the moment (graphics card malfunction issue) I have gone back to Windows on a laptop (64 bit) and have need to edit this booklet now. I do not know what version I have on the Linux machine.

So I installed the latest version of Scribus on my win10 computer, but the file will not open. It shows this error.

Screenshot of error attached

I had installed v 1.4.8 and got this error. Am not sure of the synchronisation of versions between linux and windows.
I then went and installed the 1.5.7 version for win10 (64), but got the same error. (p.s. this version seemed to also be called 1.4.8 even though I double checked I was pulling the 1.5.7 version from the net. The about screen also showed 1.4.8 )
I tried to open other .sla files but got the same error each time.

I have also attached the file that is causing this error to this thread as well.


Can anyone suggest a fix for this problem?

Thanks

toyotadesigner

  • Guest
Re: Fatal error - cannot open file
« Reply #1 on: January 18, 2022, 07:29:46 pm »
I've checked your document. On my system, there are all fonts missing, which is obvious because I didn't install your fonts.

Your warning reads: »The file maybe damaged or may have been produced in a later version of Scribus«

So check the versions you have used, and make sure the 1.5.7 is really installed. You can see it at the very top of the window, where the version number is displayed. If it is called 1.4.8 it is not the latest version.

Maybe you have a nightly build installed on your Linux machine?

core

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
  • Scribus User
Re: Fatal error - cannot open file
« Reply #2 on: January 18, 2022, 07:54:18 pm »
I have had scribus installed on my linux machine for at least a year. I cannot recall ever updateing the version during that time.

Since this machine is out of order at the moment, cannot check the version that was used to create the file in question.

When I installed 1.4.8 onto my windows machine and got that error. I went directly to the download location again and looked for the unstable dev builds. I thought I was downloading 1.5.7
I believe now I was erroneously still downloading 1.4.8  behind that big green button on the nightly builds page.

p.s. I just went back to look at the nightly builds and had to look around to find the actual 1.5.7 version.
I've installed it now and it opens my file OK. As you said thought, fonts are not there but I can handle that.
So it seems either there is a thing with linux vs windows builds, or there is a compatibility bug in 1.4.8.
I am no programmer so no idea past the obvious.

Hope this version is stable enough for me to do my edits and save to PDF

utnik

  • Hero Member
  • *****
  • Posts: 1669
  • Karma: 18
Re: Fatal error - cannot open file
« Reply #3 on: January 19, 2022, 06:11:48 am »
hi core

your file was produced with scribus 1.5.5. (the second code line of the .sla file shows: <SCRIBUSUTF8NEW Version="1.5.5">)

utnik

core

  • Newbie
  • *
  • Posts: 14
  • Karma: 0
  • Scribus User
Re: Fatal error - cannot open file
« Reply #4 on: January 19, 2022, 08:42:50 am »
Ok, that makes sense.

The error shown by Win10 v 1.4.8 correctly defined the problem. A version mismatch.
I gather then that Linux versions are ahead of Windows version. Not sure if this is just numbering or actual features.

Today I will look at editing this file in Win10 V 1.5.7.
Hope I sidestep the bugs

thx

 

palmate