Scribusoid

Author Topic: Version 1.7.0 for macOS  (Read 221 times)

toyotadesigner

  • Full Member
  • ***
  • Posts: 192
  • Karma: 0
  • Active Scribus Mac User
    • architectural, industrial and business photographer
Version 1.7.0 for macOS
« on: May 14, 2022, 10:39:14 am »
OK, the 1.7.0 for macOS is available. I was wondering that there was no version 1.6.0…

Anyway, I had only few crashes over the past decade with Scribus, but this version crashed after 10 minutes due to signal XYZ.

In addition, I had to learn the hard way that the files I have modified with 1.7.0 are not backwards compatible, so if you should use the new version, make sure you have a backup of your old files.
Nur wenige wissen, wie viel man wissen muss, um zu wissen, wie wenig man weiss.
Only few know how much you have to know to know how little you know.
Sólo unos pocos saben lo mucho que hay que saber para saber lo poco que se sabe.

— Werner Heisenberg [German theoretical physicist]

RodneyLee

  • Sr. Member
  • ****
  • Posts: 283
  • Karma: 3
  • Scribus User
Re: Version 1.7.0 for macOS
« Reply #1 on: May 14, 2022, 03:27:32 pm »
where did you find 1.7.0, I don't see it on the Scribus website

toyotadesigner

  • Full Member
  • ***
  • Posts: 192
  • Karma: 0
  • Active Scribus Mac User
    • architectural, industrial and business photographer
Nur wenige wissen, wie viel man wissen muss, um zu wissen, wie wenig man weiss.
Only few know how much you have to know to know how little you know.
Sólo unos pocos saben lo mucho que hay que saber para saber lo poco que se sabe.

— Werner Heisenberg [German theoretical physicist]

utnik

  • Hero Member
  • *****
  • Posts: 1654
  • Karma: 18
Re: Version 1.7.0 for macOS
« Reply #3 on: May 14, 2022, 07:52:24 pm »
hi toyotadesigner

OK, the 1.7.0 for macOS is available. I was wondering that there was no version 1.6.0…

1.6.x will be the next stable branch. 1.7.0 is a way to keep developing things that may not make it to 1.6.0…

Quote
…I had to learn the hard way that the files I have modified with 1.7.0 are not backwards compatible, so if you should use the new version, make sure you have a backup of your old files.

well. at he moment the hard way isn't that hard. the files are still compatible, but scribus doesn't know that – and it may change with the next 1.7 release…
you just need to open the .sla file in a text editor and change the version number in the first line to '1.5.8' and scribus 1.5.8 will open it again.

utnik

toyotadesigner

  • Full Member
  • ***
  • Posts: 192
  • Karma: 0
  • Active Scribus Mac User
    • architectural, industrial and business photographer
Re: Version 1.7.0 for macOS
« Reply #4 on: May 14, 2022, 10:02:46 pm »
Hi Utnik, thanks a ton for your information, that trick is a real time saver!
Nur wenige wissen, wie viel man wissen muss, um zu wissen, wie wenig man weiss.
Only few know how much you have to know to know how little you know.
Sólo unos pocos saben lo mucho que hay que saber para saber lo poco que se sabe.

— Werner Heisenberg [German theoretical physicist]