Font printing issues

Previous topic - Next topic


I,'m asking here, but I'm not sure this issue depends on PDF creation process rather than some other reason.

I usually produce a magazine PDF for a little magazine and send it to the same printing press shop. The magazine layout and fonts are almost always the same, but seems they encountered a issue with a font this time:

Liberation Serif Italic

It is a really generic font, and it ever worked in previous times.

The shop says they can print that PDF on one printer, but they can't on their "film printer" (the same they had previous times). They also tried ti install "Liberation Serif" family fonts, even if I usually embed all fonts in my PDF...
I also tried to check it with a little command line tool called "pdffont" and it returns:

name                                 type              encoding         emb sub uni object ID
------------------------------------ ----------------- ---------------- --- --- --- ---------
BeautifulES                          TrueType          Custom           yes no  no      15  0
BeautifulES                          TrueType          Custom           yes no  yes      9  0
BeautifulES                          TrueType          Custom           yes no  yes     13  0
LiberationSans-Bold                  TrueType          Custom           yes no  no      31  0
LiberationSans-Bold                  TrueType          Custom           yes no  yes     21  0
LiberationSans-Bold                  TrueType          Custom           yes no  yes     25  0
LiberationSans-Bold                  TrueType          Custom           yes no  yes     29  0
VACMZM+LiberationSans-Italic         CID TrueType      Identity-H       yes yes yes     36  0
HCHTCG+LiberationSans                CID TrueType      Identity-H       yes yes yes     41  0
LiberationSerif-Bold                 TrueType          Custom           yes no  no      57  0
LiberationSerif-Bold                 TrueType          Custom           yes no  yes     47  0
LiberationSerif-Bold                 TrueType          Custom           yes no  yes     51  0
LiberationSerif-Bold                 TrueType          Custom           yes no  yes     55  0
RSGXTV+LiberationSerif-BoldItalic    CID TrueType      Identity-H       yes yes yes     62  0
LiberationSerif-Italic               TrueType          Custom           yes no  no      78  0
LiberationSerif-Italic               TrueType          Custom           yes no  yes     68  0
LiberationSerif-Italic               TrueType          Custom           yes no  yes     72  0
LiberationSerif-Italic               TrueType          Custom           yes no  yes     76  0
QYADNH+LiberationSerif               CID TrueType      Identity-H       yes yes yes     83  0

So Liberation Serif italic should be properly embedded in my PDF... And actually the can print to the other printer...

I send them the links to the PDF uploaded to various online storage services "mega" "yandex" and "GDrive":
At the end they said they solved by launching the printing process to the film printer, but from the PDF opened within the browser.
I don't know what exactly could change... but it worked.
If they download the PDF file and then open it with their PDF viewer (I think Adobe Reader or similar on windows), then launch printing.. the printer doesn't render properly "liberation serif italic" font.

When I'll go to get the magazines I'll ask for some explanation. In mean time...
Have you any ideas about what could be the reason of that issue?

Thanks in advance!


Is the font »Liberation Serif Italic« a professional OpenType font?

What do you mean by »really generic font«? I've never heard of it, and I can't find it in my font collection of over 2,800 professional OpenType fonts.

Rule of thumb: Use TrueType fonts, and you'll run into trouble, use professional OpenType fonts, and chances are extremely high that your material will flawlessly print anywhere.


This should be the official Liberation fonts project site:

Font is designed by Steve Matteson from Red Hat.
You can find infos also on adobe database:

Here you can find a reply that explain what Liberation fonts are designed for:

QuoteLiberation is the collective name of four TrueType font families: Liberation Sans, Liberation Sans Narrow, Liberation Serif and Liberation Mono. These fonts are metrically compatible with Monotype Corporation's Arial, Arial Narrow, Times New Roman, and Courier New (respectively), the most commonly used fonts on Microsoft Windows operating system and Office suite, for which they are intended as free substitutes.

Anyway the question is:
why when printing to printer-1 it works, but doesn't work if the same PDF is sent from the same machine to printer-2.

I cannot understand the reason of this "strange behavior":
- if the font is embedded, their operative system shouldn't be needed to have that font installed.
- if they have any problem with a specific printer only, I would say that printer cannot "translate" properly that font.
- but if finally they were able to print by opening the PDF using the browser and launch from there.. how the printer has been able to "translate" properly that font?

Anyway thanks for your suggest about OpenType Fonts, I'll ask to printing press shop a preview check on all fonts used in my document.
Is there any standard template page to try a font against a set of PC-OS and Printer?
I suspect also the font size could interfere to the printer.


A standard postscript (laser) printer is simpler than a professional printer. The professional printer usually does have a RIP (Raster Image Processor), which translated all objects of a PDF to the printer language, which usually runs PostScript Level 3.0.
If the standard postscript printer does print the file, it could be that it runs PostScript Level 2.0 (my guess).
Your guess with the translation is the weak link, correct. The variables are: PostScript Level 2.0, PostScript Level 3.0, RIP with different postscript levels...

The font size is not relevant at all.

Printing from a browser — or i.e. from »Preview« on macOS — is a different story: You can even print to a non-postscript printer, because the browser or app renders the page(s) completely for any printer, even for a cheap inkjet printer. In this case, the printer is just a dumb device that sprays ink onto the paper, that means the app »translates« the PDF as good as it can.

Example: I can print a Scribus document to a large format printer, if I use a Software RIP, which translates PostScript Level 3.0. The LF printer doesn't have a built-in RIP. If I want to print the Scribus document to my cheapo inkjet printer, I have to generate a PDF (any version) and print that PDF to my inkjet printer with the »Preview« App. There is no way to print directly from Scribus to my cheapo printer.

I know, this sounds complicated, and believe me, it is complicated  ;D


How the shop prints my file:
1. they print on transparent plastic sheets with a quite simple HP printer: LaserJet 709 - m712 (I don't know if this model has got special RIP or is PS level 3 compliant)
2. these sheets are then "installed" on a metal plate provided with a special film of photosensitive polymer
3. the plate is selectively exposed to the light passing through the printed sheet above, used as a mask
4. at this point the plate contains the printed image in a latent stated and is immersed in a developer solution
5. at the end the plate surface became selectively ink-repellent, it is inked and installed on a
   mechanical press, and finally printed on final white paper.

Our issue is at the first point.
After they downloaded my file it has somehow changed when printing, so the "liberation serif italic" font is replaced.
And I'm not so sure this caused by the printer...
I went to printer press shop with some PDF of the same file I had uploaded online and shared with them.
First one has been exported by Scribus with all fonts embedded. The second one has been exported without fonts, by the option fonts to outline.

From PDFs in my USB key copied on their desktop and opened with Adobe Acrobat Reader, both the files are printed properly with their printer (the HP model reported above). So we cannot realize where that strange font (quite similar to liberation sans italic eventually) was exactly popped out from a week ago.

Anyway seems the issue could be always solved by choosing "fonts to outline" when exporting from Scribus to PDF.
In a preview, the fonts in that file (outline mode) seem to have just a bit darker appearance compared to the other with embedded fonts. It is more than acceptable I think, and it seems really "solid" in preserving original shape of used fonts during all document share and printing process.

Could that be the best solution to not stumble upon this problem in the future?
Thanks for all replies!   ;)


The printer specifications are here:

It has features following Languages: HP PCL 6, HP PCL 5e, HP Postscript 3 emulation, native PDF printing (v 1.4)

Whatever they mean with »HP Postscript 3 emulation« — it is only an emulation, not original Postscript (which would be more expensive). That means that the proprietary HP emulation substitutes fonts that are not included in the basic set of 35 typefaces, which results in a substitution of your font. And whatever PDF printing (v 1.4) means — that it can print only PDF files you have exported with Scribus using the PDF 1.4 Standard? In this case, you are limited to the PDF 1.4 standard.

Fonts to outline will blow up the file size tremendously, and the font will be a tad thicker when printed, which is inherent to the »font to outline« option.

Pretty weird print setup. Sounds to me like 1985, but not 2022...  Usually you have »file to plate« processes today, meaning you send the file directly to a printing plate without any steps in between.


From Scribus I do export to PDF v1.4, it should be a safer choice exactly for preventing compatibility issues. My files are usually really simple and doesn't contain any exotic graphical element, so that actually doesn't represent a limit for my needs.

QuoteThat means that the proprietary HP emulation substitutes fonts that are not included in the basic set of 35 typefaces, which results in a substitution of your font.

Sounds reasonable, but it doesn't make clear why the printer has worked properly this time, when we launched printing process by the PDF file on my USB key just opened in Adobe Acrobat (the file version with embedded fonts, the same I had uploaded to the online storage service and shared with them). I suspect some other issues in between the download and printing when I sent the same file.