Author Topic: Hyphenation Special Settings  (Read 341 times)

tallytta

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Hyphenation Special Settings
« on: February 08, 2022, 03:14:31 pm »
I've been trying to find some special hyphenation settings with no success.

How could I set up hyphenation in a way that proper nouns don't get hyphenated?

Also, how to avoid hyphenating the last words on the pages, so they don't get divided between 2 pages?

Is there a way to do it (automatically or manually)? Any advice is appreciated.

toyotadesigner

  • Full Member
  • ***
  • Posts: 202
  • Karma: 0
  • Active Scribus Mac User
    • architectural, industrial and business photographer
Re: Hyphenation Special Settings
« Reply #1 on: February 08, 2022, 07:02:55 pm »
See attached files

Additional information is here: https://sinestesia.co/blog/tutorials/justifying-like-a-boss-in-scribus/
Nur wenige wissen, wie viel man wissen muss, um zu wissen, wie wenig man weiss.
Only few know how much you have to know to know how little you know.
Sólo unos pocos saben lo mucho que hay que saber para saber lo poco que se sabe.

— Werner Heisenberg [German theoretical physicist]

tallytta

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Hyphenation Special Settings
« Reply #2 on: February 09, 2022, 01:48:11 pm »
Thanks for this. I can see how this could work for proper nouns, but I'd imagine that even if I compiled all the last words being hyphenated and getting divided between 2 pages at the moment, as soon as I put them in the list, the whole text would get messed up and new words would get hyphenated the same way (if a word or a lot words are no longer hyphenated this would move the text and end up hyphenating other words).

Any ideas on that regard? I hope all the rambling above made some sense!

Ewac

  • Newbie
  • *
  • Posts: 47
  • Karma: 0
  • Scribus User
Re: Hyphenation Special Settings
« Reply #3 on: February 10, 2022, 08:50:42 am »
I have had a similar situation and have not been able to find a setting that would prevent hyphenation across columns or pages. It would be a very helpful feature.

Other than that, you might just need to go through your document and manually dehyphenate the words at the end of your page.
select word / go to "extras" / "dehyphenate text"
You can also use manual tracking in addition, to spread the words out evenly in that last line and in the next line/first of next page, that will be effected by changing the previous line.
select line / go to "text properties" / "advanced settings" / "manual tracking"

hope that helps and if anyone has a better solution, I'd be happy to know!

 

palmate