Scribus > Beginner Talk

Configuring Render Frames


Dear Forum,

I am just starting to use Scribus and am going through the manual on the wiki. I plan on using music notation, so I was happy to see that you can embed LilyPond into the program (as opposed to exporting Finale files as graphics, but I digress...). I thought I'd test drive this feature but when I tried to create a render frame, I got the following error message as soon as I clicked on the tool icon:
"Your Render Frame configuration seems to be invalid. Please check the settings in the External Tools section of the Preferences dialog."

What settings do I need to enter in order to make this work? I have LilyPond installed, but I can't really parse the External Tools section to understand what I should change. I am not seeing this information in the documentation on the wiki.

Your help is appreciated.


Dear Forum,

More information:

I realized that I had updated LilyPond, but had not opened it. I had that typical MacOS issue with non-AppStore programs (you have to grant permission to open it in Security in Preferences) and thought that might be the problem. But unfortunately, once I resolved being able to open the program, I continued to get the same error message about configuration.

Next, I saw that there is a "rescan" button in the External Tools dialog. Upon clicking that, I got the error message "Uniconvertor executable not found!" I thought maybe that's the problem. So I looked up Uniconvertor on the web, downloaded it from here , installed it, and there is no program on my computer called Uniconvertor. Searching for it only turns up the installer disk image.

So, is the problem the lack of Uniconvertor? Does it not actually work with OS 12? Is there anyone out there with any thoughts on the matter? Bueller?


Dear Forum,

I'm going to continue talking to myself here...

So, I saw that the official version of 1.5.8 was released (I was using a nightly build previously). I have installed it, but the problem remains:
• I cannot create a render frame, because the tool is somehow not configured properly.
• I cannot configure it properly, because there seems to be little information on how to troubleshoot this issue.
• In external tools, when I click "rescan," it says Uniconverter executable cannot be found.
• I downloaded Uniconverter, but that installer does not seem to work, as no program manifests despite the installer seeming to work normally.

Any thoughts are most welcome.


Hi Andrea, like you I came here for the same error message, although I got it for reasons unknown... I just opened a file I have been working on for ages, and the error occured.  For me it seems it might have been the Adobe Acrobat link was invalid after I think Acrobat updated itself.  I've linked that correctly, and the error went away.

I apologise if this doesn't help - but despite nobody replying to you when you had the problem, your thread pops up high in Google, so I guess a few other people are having the same trouble... so I wanted to add to the info here for others in the future.

Of course I am only assuming that my solution fixed my problem, but I haven't seen the error since.

Cheers, Steve

I get the same error message with 1.5.8 from a flatpak install
the render frame does not work

in 1.5.7 from the fedora 36 repo the render frame will work
now, how to get uniconvertor working in fedora ??? can't find a libmagickwand-dev


[0] Message Index

Go to full version