Author Topic: "Interesting" display problems under Linux  (Read 238 times)

grue

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Yay!
"Interesting" display problems under Linux
« on: October 04, 2021, 04:22:38 pm »
Hello everyone!

I'm new to this forum and to using Scribus, so I apologize in advance for any stupid things I might write.

Anyway, here's my problem:

When using Scribus 1.5.7 (yes, ik it's a development version, but it was the first option offered by Manjaro's pamac) on one of my computers I have display/graphics problems in the UI when either choosing the font in a text frame border or wanting to change the line style. See the attachment screenshots for details.

System details:

System:
  Host: helix Kernel: 5.4.148-1-MANJARO x86_64 bits: 64 Desktop: GNOME 40.4
  Distro: Manjaro Linux
CPU:
  Info: Dual Core Intel Core i5-3427U [MT MCP] speed: 2383 MHz
  min/max: 800/2800 MHz
Graphics:
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: Lite-On Integrated Camera type: USB driver: uvcvideo
  Device-3: Lite-On Integrated Rear Camera type: USB driver: uvcvideo
  Display: wayland server: X.org 1.20.13 driver: loaded: i915
  note: n/a (using device driver) - try sudo/root
  resolution: <missing: xdpyinfo>
  OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2)
  v: 4.2 Mesa 21.2.2

What's funny is that when I use Scribus on my desktop computer that is running exactly the same software setup, but uses an (old) ATI graphics card (idk which one atm as I'm writing this on my affected laptop computer) there are absolutely no glitches.

I tried using a different kernel (5.4) as I'm aware that the i915 driver has some flaws (different story), but to no avail.

Any suggestions on what might be going wrong here and how to fix it?

Thanks very much to everyone!


AdmFubar

  • Jr. Member
  • **
  • Posts: 79
  • Karma: 1
  • Scribus User
Re: "Interesting" display problems under Linux
« Reply #1 on: October 04, 2021, 10:54:30 pm »
This first image looks like a driver issue. I've had similar issues with firefox on opensuse.The second looks more like an issue with the de. It has been years since i've used gnome, and cant remember if there are any tweaks to the user interface that can change the style, as in kde. Something to look into there.

grue

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Yay!
Re: "Interesting" display problems under Linux
« Reply #2 on: October 05, 2021, 03:10:33 pm »
Well, what's funny is that on another laptop with Intel graphics and also using the i915 driver these issues do not exist.
Guess I'm going to dig into the driver's bugtracker...

Thanks for your help!

AdmFubar

  • Jr. Member
  • **
  • Posts: 79
  • Karma: 1
  • Scribus User
Re: "Interesting" display problems under Linux
« Reply #3 on: October 06, 2021, 11:12:11 pm »
Same specs for the laptop? Same distro?

grue

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Yay!
Re: "Interesting" display problems under Linux
« Reply #4 on: October 07, 2021, 01:09:29 pm »
Same distro, but not same specs. Well, both are Thinkpads, but integrated graphics of the affected computer is of an older version.


AdmFubar

  • Jr. Member
  • **
  • Posts: 79
  • Karma: 1
  • Scribus User
Re: "Interesting" display problems under Linux
« Reply #5 on: October 08, 2021, 05:24:44 am »
Ah that might be it... driver was depreciated for the older hardware. I would check the hardware info against what is supported in the kernel to see if there was a change. Or bug was introduced in the current driver.

How old is the affected machine?

grue

  • Newbie
  • *
  • Posts: 4
  • Karma: 0
  • Yay!
Re: "Interesting" display problems under Linux
« Reply #6 on: October 08, 2021, 03:16:25 pm »
The laptop is about 8 years old, it's a 1st generation Thinkpad Helix Ultrabook.  Works fine except for that bug.

Graphics adapter is a Intel HD Graphics 4000. In my other, not affected, device it's  a HD Graphics (BYT) -- it's an ever older Thinkpad 11e using an Atom Z36xx CPU and its integrated graphics.