Scribus > Linux

Installing Scribus 1.5.x on raspberry pi (Raspberry Pi OS)


I need to get Scribus 1.5.x working on a raspberry pi 4, but so far I have only been able to install 1.4.x
I used the terminal to install Scribus and got 1.4
In the terminal I also tried scribus-ng but it also installed 1.4.x
I downloaded the appimage from the 1.5.x page but the downloaded file is also 1.4.7.tar.xz

There was a post from 2017 and someone suggested compiling it though I have never done that before.
Is compiling the only way to go?
I haven't been able to find any good resources on how to compile an app for the raspberry pi, if that is the way to go, could someone help me out and send me some links?


So I kept trying. The closest thing to success was by downloading the source and running:

--- Code: ---sudo apt install cmake
cd /home/pi/Desktop/scribus-1.5.7
mkdir build
cd build
~/Desktop/scribus-1.5.7/build $ cmake -DUNIX_STRUCTURE=1 -DCMAKE_INSTALL_PREFIX=/usr ..

--- End code ---
I got the following error

--- Code: ---CMake Error at CMakeLists_Dependencies.cmake:13 (find_package):
  By not providing "FindQt5Core.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5Core", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5Core"
  (requested version 5.14.0) with any of the following names:


  Add the installation prefix of "Qt5Core" to CMAKE_PREFIX_PATH or set
  "Qt5Core_DIR" to a directory containing one of the above files.  If
  "Qt5Core" provides a separate development package or SDK, be sure it has
  been installed.

--- End code ---

So I tried to install QTCore5 using a few different methods, but the most successful was the guide/script from here:

Which gave me the following error when i ran the bash script :

--- Code: -----2021-08-13 17:34:38--
Resolving ( failed: Name or service not known.
wget: unable to resolve host address ‘’
Error downloading cross compilation tools

--- End code ---
Actually, links from another site gave me similar errors. It seems to me that the dependancies are no longer online?

So next steps, I managed to download /gcc-4.7-linaro-rpi-gnueabihf online, it wouldn't unzip but I found this page online:

Unzipped the file, but couldn't see how to install it.
Tried to install QT5 again with the script and same error. So that is where I am right now.

Next step:
Tried doing:

--- Code: ---sudo apt-get install ia32-libs
--- End code ---

--- Code: ---Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package ia32-libs

--- End code ---


--- Code: ---~/Downloads/gcc-4.7-linaro-rpi-gnueabihf $ sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0

--- End code ---

--- Code: ---Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package lib32z1
E: Unable to locate package lib32ncurses5
E: Unable to locate package lib32bz2-1.0
E: Couldn't find any package by glob 'lib32bz2-1.0'
E: Couldn't find any package by regex 'lib32bz2-1.0'

--- End code ---

So I have solved the problem by using a Flatpak from It doesn't load when I click on the desktop shortcut, but it loads if I use the terminal. I successfully managed to open up one of my documents from 1.5.x. Now I just need to install the necessary fonts.
If you have any suggestions about the shortcut issue or you think there is a better alternative, let me know.
Hopefully this will help someone!
How do I mark this as solved?


[0] Message Index

Go to full version