Scribus > Text and Typography

Any guide to quickly applying styles?

(1/1)

OwenNZ:
My usual way of working is to apply the paragraph style "Body" that I've set up to all text, then I go through and apply a subhead paragraph style (independent of the Body style) to subheads. Unfortunately it doesn't seem to work cleanly in Scribus: after I apply the Subhead style it doesn't alter the character style that I thought I'd specified in Subhead, it sticks with Body, and only changes to the Subhead style after I click on the Character style trash icon. Is this how it is supposed to work?
I'm used to the Pagemaker/InDesign style paradigm, so I'm a little confused.

utnik:
hi owen


--- Quote from: OwenNZ on June 17, 2021, 03:07:01 pm ---…Is this how it is supposed to work?
--- End quote ---

no, normally it is not – but you may have applied a paragraph style and a character style to your text. if you did so, i would expect what you describe.
separate character styles should be used when only a part of a paragraph needs to be formatted in a special way. (and then you wouldn't like to see this special formatting disappear when changing the paragraph style…)

if my guess is right, just define your standard character settings as a part of the paragraph style. i recommend that you should never apply a separate character style to a whole paragraph.

utnik

Spilly:
@OwenNZ

You describe exactly what I do, and for me, it seems to work.
The important thing is that both Body and SubHead must be fully specified **Paragraph** styles

I apply "Body" Style to the empty frame; Body includes a default char style of the desired font settings
Then I import the text - either in Story editor; or Get Text; or a plain text Paste

In my case that gives me all paragraphs with 6pt spacing after, but I want my subheads to be Bold with zero spacing after.
Personally I find working in Item Edit mode easier than in Story editor at this stage

The F3 Text palette shows Body style & [Default Character Style]. Don't touch the lower dropdown.
In item edit mode, place the cursor anywhere in a subhead para, and set F3 paragraph style to SubHead.
Repeat for each subhead para.

For me, this works and formats the selected paragraphs as desired.


I have issues with Get Text, but that's another matter really.
To make the importer work you need to set which importer to use; it doesn't set the importer from the imported filename extension, as it should; but at least it remembers what you did last time.
 

Hope this helps - either you or any other browsing the page

Spilly

OwenNZ:
Thanks! I'll give it a go in my next job.

Navigation

[0] Message Index

Go to full version