Author Topic: Error Message: Missing XObject  (Read 728 times)

Gail W

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Error Message: Missing XObject
« on: February 22, 2021, 06:03:04 pm »
I am working in Scribus 1.4.8 and am fairly new to this whole process. After exporting file to pdf, I am uploading it to a self-publishing site (lulu.com, if that matters). It uploads the file, then comes back with the following error message:

Error Message: Missing XObject

No other details, no page number, nothing. I have created and uploaded other pdfs to this site with no problem using the same settings (that is, whatever Scribus defaults to), and I do not understand what or where the problem is. Their tech support is so far silent.

Any suggestions greatly appreciated, as I have no idea where to start.

Gail

mnawij

  • Sr. Member
  • ****
  • Posts: 339
  • Karma: 1
  • Scribus User
Re: Error Message: Missing XObject
« Reply #1 on: February 22, 2021, 10:56:10 pm »
Hi Gail W,

This is a definition from Adobe's website of emitting XObjects:  Emits PostScript form objects for Form XObjects within the PDF. Selecting this option reduces the overall size of the print job, but it could increase the printer memory that is used. A form XObject is a container of graphics objects (including path objects, text objects, and sampled images) within the PDF. Form XObjects create a single description for complex objects that can appear many times in a single document, such as background images or company logos.

What this does is reduces the overall files size of the pdf. Not sure of the fix, I would open the file in Acrobat Pro and try re-saving the pdf file first.

Regards,

mnawij

Gail W

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Error Message: Missing XObject
« Reply #2 on: February 23, 2021, 03:12:49 pm »
Thank you for replying. It is helpful to know more about what the error message means.

I think either I somehow changed a setting in the pdf dialogue, or there is just a hiccup in my software set up. I ended up collecting and moving the files to a new computer, downloading Scribus 1.5.5 (?) there, and everything worked just fine.

I'll try reinstalling on my computer before my next project. Appreciate your help.

Gail W