Cannot browse any directory

Previous topic - Next topic


I downloaded Scribus Version for OS X (I run Catalina).
I open the app.
I make a new document.
If I want to add an image, I add the image frame. If I double-click, I can browse directories on my mac, but unfortunately im the preview all is empty. No documents. I can only open an image if I now drag it from a directory to the window in Scribus.
Scribus cannot access any files from the browse window.
How can I solve this.
I've searched during at least one hour online and on the forum without success. I have a german system so all is in german, not sure I looked for the correctkeywords (I looked for browse, authorize, directories, not showing and so on).

I'm showing here 2 screenshots.
If I drag a .png from the desktop to the brwose window for testing, then it will show up. But the browse itself does not see any documents. No matter if I'm on "all files" or just "supported files". Nothing' shows up.


you have a "/" in the File Name line of the dialog. I bet this does a bit of weird filtering on mac os. Try removing it and see if it shows the files in the directory.

Using Scribus 1.6.1, openSUSE 15.6
Advanced hobbyist


Quote from: AdmFubar on February 06, 2021, 09:29:40 PM
you have a "/" in the File Name line of the dialog. I bet this does a bit of weird filtering on mac os. Try removing it and see if it shows the files in the directory.
But the dialog is given by Scribus. I mean there's no way to change it. I can navigate via this dialog (pull-down) through all directories, but the issue is that no content is displayed.


Im running 10.14.6 and Scribus 1.5.6 and have no issues displaying the preview.

I also tested it on Big Sur and the previews show no problem.

Perhaps have you tried changing your scribus language to english & restart scribus?, maybe there is a bug with german language.


Hi there,

I'm having the same issue.

I've just bought a new Windows 10 laptop and installed Scribus 1.5.7 on it. I used to run an older version of Scribus on my old Windows laptop and I never had any trouble browsing directories for files to import. Like the person who first posted about this issue, I can create an image frame and select the 'get image' option. However, it only gives me very limited directories/folders to open and browse through.

I have dedicated folders within my Documents folder for my image files but I can't see these folders when browsing for them from the 'get image' command. I wonder if this is because my main Documents folder is now synced with One Drive whereas this folder was on my hard drive on my old computer?

I found a workaround in the meantime. I can access my Downloads folder from the 'get image' command so I'll just copy the image files I need to that folder for now. It's messy and not where I want image files to be stored, but it means I can continue working on the document until I find a solution.



That's handy to know. Thank you. :)


I've never used this type of import. I'm using XnView MP for macOS, where I select several image files and drag them onto a page in Scribus.

Your sample showed a *.png, which can have some weird subformats (interlaced, reduced colors, transparency, even all 3 versions in one file). Did you ever try to place a JPEG or TIFF file? Just tried these formats with your method here (huge 48 bit TIFF with 635 MB), everything is perfect, though it takes some time to be displayed in the preview area.

BTW, because the browse window is kind of small, it might help to scroll sideways or to enlarge it to see more folders on your machine.


Thanks, toyotadesigner,

I appreciate your help.

The issue is not that I can't see the files because the window is too small. It's that I can't see the folders or files I want to use in the first place. Those pathways are just not there. yet, when I view the folders and files via Control Panel or File Explorer, I can see them just fine.

Also, I've accessed all sorts of file formats using the 'Get Image' function in the past, including PNG files. This says to me that the issue is with Scribus, Windows 10 or both, rather than with the files themselves.

Drag and drop does work, though. I just hadn't accessed image files that way before.


Hi Rosemary, Scribus seems to always start in the »USER« folder, which in Unix and macOS is something like ~/Users/username. For you — the user — it looks like »/« or just a blank window, or it starts with the last folder where you saved your Scribus file. In my case, it always falls back to the »Documents« folder, even though the Scribus folder is located even further down the tree. Never managed to understand the logic behind this behaviour.

[attachment deleted by admin]


Can you set your default paths to the locations needed?


You are right — just checked the »Preferences« and there it is in the »Paths« section. Never checked it before <sigh>