Author Topic: Image appears skewed in its frame  (Read 600 times)

Spilly

  • Newbie
  • *
  • Posts: 21
  • Karma: 0
  • Scribus User
Image appears skewed in its frame
« on: November 24, 2020, 04:11:13 pm »
Using Scribus 1.5.6.1 x64 under Windows 10

I have a hi-res JPG image (2953x1970 px as reported Windows Paint)
I created an image frame of the desired width (91mm), but oversized in height, with a 1 px black bounding border (stroke not fill)
This frame is at level 12, above a larger background bordered frame at level 1
Get image shows the top left only (of course)
I then resized the image to fit the frame, with the over sized height as expected.
I then resized the frame to fit the image.
The resulting frame measures 91x60.770mm

I find that the image appears skewed within the frame, as though I had rotated the image anti-clockwise by 1 degree or so.  Needless to say, I have not rotated the image at all.

The 1 px border on the LH edge starts at X-pos 9.000mm as expected
but finishes a pixel displaced to the right
The measure tool reports 0.299mm
See screen snip at attached, taken at zoom 400

The unwanted white gap is also visible on the PDF when printed.

Is this a bug?
Can I do anything to resolve it (apart from my own suggestion below)?
Should I report it to the developers? If so please advise how to do so



There is an obvious workaround:
Just displace the image 2mm down and right, and  resize it to suit.
The eye will not then see the tiny narrowing of the surrounding white LH border
spilly
Win 10 bog std laptop
Scribus v1.6.1 64bit
in IT for 60 odd years, but little DTP experience

utnik

  • Hero Member
  • *****
  • Posts: 1590
  • Karma: 17
Re: Image appears skewed in its frame
« Reply #1 on: November 24, 2020, 06:16:04 pm »
hi spilly

can you reproduce the issue?
i suppose an unintended manipulation as the source of the skewing…

utnik

Spilly

  • Newbie
  • *
  • Posts: 21
  • Karma: 0
  • Scribus User
Re: Image appears skewed in its frame (solved)
« Reply #2 on: November 24, 2020, 07:31:50 pm »
@utnik That was good advice... No I can't reproduce it on a new SLA

On the original SLA, I had been messing about with Editing the Image contour line in the Contour edit menu of the F2 Palette Shape dropdown, but I had definitely reset all edits.

I suspect that's what at the bottom of my problem.

I since discovered how to control the whitespace depth correctly between the first line of text  and the bottom edge of the image above, in F3 Text Properties.
I guess there is no need to fret about contour lines unless you have irregular image shapes, - and I haven't.

As you can probably tell, I v much a newbie to DTP, and to Scribus even more so.

Very happy to flag this as solved, but don't see how to apart from editing the header, so I have

Thanks
spilly
Win 10 bog std laptop
Scribus v1.6.1 64bit
in IT for 60 odd years, but little DTP experience