Scribus > Linux

Install stable version, not preview, on Scribus in Linux Mint 20

(1/1)

antonfsp:
Hi all!
I'm new in this forum and new in Linux too. I have been using Scribus in Windows for the last years and I want to continue with it now in Linux Mint, creating new and editing all documents. When I try to install Scribus, using both the Software Management and the terminal, I get the version 1.5.5 of Scribus and not the stable version series 1.4. I'm sure that installing the stable version has to be something very easy to do, but my knowledge about linux is very limited yet and I couldn't figure out checking the forums how to do it. Could someone help me?
Thank you very much!

a.l.e:
if your distribution does not ship qt4 anymore, than there is no (simple) way to install the stable version of scribus. sorry.

RodneyLee:
why do you want 1.4xx?

sunnyanneholliday:
I am having the same problem. I have Ubuntu 20.1. The software manager automatically installs the unstable version, which will not run at all (just opens and locks up, can't even close the application). I would like to install 1.4.8 (I believe is the most recent stable version.) I am very much a novice, but if directed to the links to download the necessary files, and given exact commands for terminal, I could do this! :)
Thanks!

mnawij:
sunnyanneholliday, two alternative options.

Try the appimage:
https://www.scribus.net/downloads/unstable-branch/

or

the flatpak:
https://flathub.org/apps/details/net.scribus.Scribus

I thought Linux Mint 20 has the flatpak repo installed by default, look there first. Both of these options install all dependencies outside of the base OS. It will take longer to start the app but that is the only difference I have noticed running it in LMDE 4.

Cheers!
mnawij

Navigation

[0] Message Index

Go to full version