Scribus > Linux

Unable to start Scribus after an update

(1/5) > >>

Dear all,
Has anyone ever had the following problem:
After updating my system, I cannot launch Scribus.
I uninstalled it then reinstalled it 5 times : it doesn't work.
When I run the program the result is: nothing opens, not even a welcome image ...
I have searched on lots of places I can not find any solution...

I notice there is maybe something related with a bad font ? I did not venture in that direction, not knowing how to do it.

I also don't know which command line I have to indicate here to be able to find a help.
I run Linux Mint 19.2 Tina on a MacBook Pro i7 Mid-2010.

In advance Thank you very much for any help

Since you are running Linux (I am on Ubuntu 20.04) it should be easy to run through some troubleshooting tests.

First can you run in terminal

scribus -v

to read the version.


scribus -h

to see the options.

Next since you mention fonts run

scribus -fi

to get font info.

And so on until you can pin down why scribus does not run.

Hello & thank you very much for the fast reply :

When I write the codes there is already a problem :

--- Code: ---root@gvp-MacBookPro:/home/gvp/.scribus# scribus -v
scribus: symbol lookup error: scribus: undefined symbol: _ZN12QApplication10commitDataER15QSessionManager
--- End code ---

And same with scribus -h & scribus -fi. It's strange no ?

Looking at this strangeness I find a similar error in an old post here :
They talk about an error with QT but I don't know what it is.

The code ldd /usr/bin/scribus is giving me the followed result :

--- Code: ---root@gvp-MacBookPro:/home/gvp/.scribus# ldd /usr/bin/scribus (0x00007ffc58ddd000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89796d0000) => /usr/local/lib/ (0x00007f8978965000) => /usr/lib/x86_64-linux-gnu/ (0x00007f897871f000) => /usr/local/lib/ (0x00007f897840a000) => /usr/local/lib/ (0x00007f8977f29000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8977c75000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8977a30000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89777b9000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8977551000) => /lib/x86_64-linux-gnu/ (0x00007f8977334000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89770a8000) => /lib/x86_64-linux-gnu/ (0x00007f8976ea4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8976c4c000) => /usr/lib/ (0x00007f89768a9000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89766a3000) => /usr/lib/x86_64-linux-gnu/ (0x00007f897631a000) => /lib/x86_64-linux-gnu/ (0x00007f8975f7c000) => /lib/x86_64-linux-gnu/ (0x00007f8975d64000) => /lib/x86_64-linux-gnu/ (0x00007f8975973000) => /lib/x86_64-linux-gnu/ (0x00007f8975754000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89754af000) => /usr/lib/x86_64-linux-gnu/ (0x00007f897527d000) => /usr/lib/x86_64-linux-gnu/ (0x00007f897507a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8974e52000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8974c45000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8974a3b000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8974703000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89744f1000) => /lib/x86_64-linux-gnu/ (0x00007f89742e9000)
/lib64/ (0x00007f897a854000) => /lib/x86_64-linux-gnu/ (0x00007f89740b7000) => /lib/x86_64-linux-gnu/ (0x00007f8973e91000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8973c83000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8973a38000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89736d2000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89734c6000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89732b5000) => /lib/x86_64-linux-gnu/ (0x00007f8973082000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8972bb4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89729b0000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89727aa000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89724d4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89722a2000) => /lib/x86_64-linux-gnu/ (0x00007f897209e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8971e93000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8971b64000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8971945000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89715c7000) => /usr/lib/x86_64-linux-gnu/ (0x00007f89713b4000) => /usr/lib/x86_64-linux-gnu/ (0x00007f897117e000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8970f4a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8970cc9000) => /lib/x86_64-linux-gnu/ (0x00007f8970a7c000) => /lib/x86_64-linux-gnu/ (0x00007f8970867000) => /lib/x86_64-linux-gnu/ (0x00007f8970663000) => /lib/x86_64-linux-gnu/ (0x00007f8970448000) => /usr/lib/x86_64-linux-gnu/ (0x00007f8970240000) => /lib/x86_64-linux-gnu/ (0x00007f896ffbc000) => /usr/lib/x86_64-linux-gnu/ (0x00007f896fda0000) => /lib/x86_64-linux-gnu/ (0x00007f896fa84000) => /lib/x86_64-linux-gnu/ (0x00007f896f86f000)

--- End code ---

Does this help?

which version of scribus did you install?

from where did you get it?

somehow, it looks like you're trying to start a scribus 1.5 on a system with qt4 or a scribus 1.4 on a system with qt 1.5...

I agree. A cursory comparison of my output using same ldd command gives this .. => /lib/x86_64-linux-gnu/ (0x00007f679bcc1000) => /lib/x86_64-linux-gnu/ (0x00007f679bb00000) => /lib/x86_64-linux-gnu/ (0x00007f679baa4000) => /lib/x86_64-linux-gnu/ (0x00007f679ba2b000)

I have ignored the dependencies which are identical when comparing outputs.

It is clear that Qt5 dependencies are missing.

[P.S.] A further quick search found this which might help explain Qt4/Qt5 de[endencies for different versions of Scribus (I use version 1.5x)


[0] Message Index

[#] Next page

Go to full version