1.5.5: Cannot access Content | Edit Text

Previous topic - Next topic


Hi All

Trustng this is the right sub-forum.

I have been a long time Scribus user since the early days and am reasonably familiar with day-to-day tasks in it.

Recently upgraded to Scribus 1.5.5 from an older version (1.4.x series).  1.5.5 is the version supplied with my latest OpenSUSE stable release.
Scribus documents were created with the old 1.4.x version and are being editted with the new 1.5.5 version.

Issue:  I have trouble getting into some of the options at times.  Particularly text boxes.  The options don't see to work as I expect.

e.g. Text Box  Editing Issue example:

1.  Created a new text box in an older document to revise the document
2.  Pasted text into it (say Ctrl V)
3.  Text is pasted into the box okay
4.  Selected the text box (there are squares & the red lines on it so it should be selected)
5.  Select Content menu (via RH mouse button)
6.  The Edit Text  With Story Editor option is greyed out (all options are greyed out, except for Clear)

This will happen consistently with this text box and others on the same page...
So I have to work around it with editing text directly on the page.

I am confused as this used to work fine for me in the older 1.4.x version.

Can any please advise what I am doing wrong or a solution?

Many thanks,


i don't know why your "edit text" entry is grayed out.

but for many years now, in frame editing has been the preferred way of editing text.

for your main problem: can you open the "windows > outline" tool and see if the text frame is in a group, is behind a rectangle...



Hi a.l.e

Thanks for your reply.

I certainly prefer in-frame editing.  However sometimes other windows appear to overshadow what I am editing in 1.5.5   
I haven't quite worked out yet how to resize some of them in this version. The corners or edges of the dialog boxes don't do anything.
It appears to be an esoteric art...

To answer your question:
I did try the Windows | Outline tool as suggested.  I could not see any grouping.   Probably because the Content | Text option decided to work again! 
So weird because I tried almost everything (except a hammer to "persuade" it) before I posted this question, including on multiple text frames in the same document.

All that was different this time was that the Linux/KDE session had been Suspended then Restored when I looked at this again today...

So I'll have another look at Window | Outline when this problem rears its head again.
BTW I did try to raise & lower the frame (I think?) that might have been greyed out as well??  All seemed a bit odd at the time.
I was wondering whether it's a bug from importing an old document...

Thanks again.



This is when I find the the Story Editor handy. In the Outline panel right click the text element you wish to modify, in the pop up menu select Content then  Edit text with Story Editor.
Using Scribus 1.6.1, openSUSE 15.5
Advanced hobbyist


Thanks AdmFubar for the note.

The original problem was that I could not see the Story Editor!

It does have its usefulness.