Community > Scribus forums

Mac wants me to update

(1/1)

Retired-Robin:
My mac, running OS High Sierra 10.13.6 keeps wanting me to update. I use an old scribus/aqua (c) 2005-2013, if I update is there a Scribus download that will be compatible please?

utnik:
hi robin

if you update your system to 10.14 (mojave), you can use scribus 1.4.8 or 1.5.5 (or even 1.5.6.svn). but as soon as you update to 10.15 (catalina), you need to use scribus 1.5.?, as catalina doesn't support 32 bit applications any more.

utnik

Retired-Robin:
Thank you for your reply. As I am in my middle 70's and not now doing any complex stuff I think I will leave things as they are. As an ex Quark Xpress user I find Scribus easy to navigate which has been a huge bonus for the last few years.

Navigation

[0] Message Index

Go to full version