Scribus > Installation and Setup

Build Scribus 1.5.5 - specfy to CMAKE libpoppler path

<< < (5/5)

scriber:
Thank you!
I'll try it too of course!   :)


PS.
An other question I was thinking...
Is there a way to build scribus statically linked to poppler?
So that there's non need to have poppler installed on the system after scribus build...?

Maybe it would be a better choice in my case, cause poppler new version is needed and used just by scribus....

scriber:
The fiel CMakeLists_Dependencies.cmake it is not present within scribus-1.5.5 sources...
Your last patch doesn't seem applicable to 1.5.5 version... If I'm not wrong.

--- Code: ---patch -p1 < $CWD/20191205-ale.diff
can't find file to patch at input line 5
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
--------------------------
|diff --git a/CMakeLists_Dependencies.cmake b/CMakeLists_Dependencies.cmake
|index 05017a973c8cd30673fd6101501e051ada3ba4c2..ad6cdbe608a9084af535b496481914f13fc4c8b1 100644
|--- a/CMakeLists_Dependencies.cmake
|+++ b/CMakeLists_Dependencies.cmake
--------------------------
--- End code ---

a.l.e:
ah, yes...

the patch is applicable, but you need to apply it to the main CMakeLists.txt

if you come to the chat we can try to sort it out...

Navigation

[0] Message Index

[*] Previous page

Go to full version