Scribus > Installation and Setup

Can't install scribus on Ubuntu 19.10

(1/2) > >>

I added scribus ppa to my Kubuntu 19.10, then after updating the sources I tried to install scribus-ng (newest version 1.5.5) but I got the following error :

--- Code: ---sudo apt install scribus-ng
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 scribus-ng : Depends: libopenscenegraph-3.4-131 but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
--- End code ---

The package libopenscenegraph-3.4-131 is available in the repository but it depends on other old package not available in Ubuntu 19.10

--- Code: ---libopenscenegraph-3.4-131 :
                Depends: gdal-abi-2-4-0
                Depends: libgdal20 (>= 2.3.0) but it is not going to be installed
--- End code ---
How can I install the latest version 1.5.5 on my machine ? I don't want to use those slow and fat standaone AppImage files !

"funny" : - )

the other day, i was chatting with our debian maintainer and said that depending on OSG adds a huge number of packages in the dependencies and basically nobody uses it from inside of scribus.

i've installed scribus-trunk on ubuntu 19.10 on monday, so i think that it should normally work and it's probably a temporary issue, until the dependencies of OSG are fixed.
from what i read in your error messages, it might be that another program you have installed keeps libgdal to an older version and OSG wants a newer one...

of course, the "fast" alternative is to compile scribus yourself... or use the appimage until the dependencies get fixed.

The libgdal is not even installed on my machine.

I installed the appimage version, but the mouse is always flickering and changes from hand to pointer when hovering over any shape (this is similar behavior that I found and still exist on windows 10-1909), this makes working with scribus impossible for me, the dark theme is really inconsistent and can't see most of checkboxes

I really need to use version ng or trunk because I have to modify my CV (created with scribus-ng) to send it to certain company this week.

I found that libgdal depends on libodbc1 and odbcinst1debian2 which both needs

--- Code: ---libodbc1 : PreDepends: multiarch-support but it is not installable
odbcinst1debian2 : PreDepends: multiarch-support but it is not installable
--- End code ---

I have 64bits machine, so does scribus need some 32bits libraries ? I used to have Ubuntu Mate for many years but scribus was installed from ppa and never needed any 32bits library !

I found that Ubuntu 19.10 can't run any 32bits apps/libraries, the 32bits support was removed from 19.10 and 20.04 and there is no way to install multiarch-support package even after enabling i386 architecture.

--- Code: ---@kubuntu-med:~$ sudo dpkg --add-architecture i386
@kubuntu-med:~$ sudo apt update
@kubuntu-med:~$ sudo apt install multiarch-support
Package multiarch-support is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package 'multiarch-support' has no installation candidate
--- End code ---
How can we use the software on our 19.10 machines ?

I resolved the problem by downloading the deb package multiarch-support from Ubuntu 19.04 and then after installing it I was able to install scribus-ng.
The problem is that package mutiarch-support which is required for libopenscenegraph was removed from 19.10 in attempt to abandon all 32bits libraries from Ubuntu in the future.

NB : The appimage is really full of bugs and not stable for use, it crashed and the mouse flickers while moving objects and is really slow to use in comparison to the installed version from ppa.
Please Please Please keep the ppa alive for future use, we really need it because those big/fat standalone apps (appimage, snap or flatpack) are full of bugs and slow to use.


[0] Message Index

[#] Next page

Go to full version