LaTeX table in Scribus

Previous topic - Next topic


I am relatively new to Scribus and have been using it to make an academic poster. Since I am familiar with LaTeX and have several equations that I need to include, I have been using mostly Render Frames with LaTeX (even for text). This has been working fine.

However I wish to include a table. I can create a table in LaTeX, but when I try to apply this script within a Render Frame in Scribus the table does not display. Any ideas what I can do?

fwiw this is my LaTeX table script:
School             & P  & W & D & L & Bonus & Points per Match \\
Manchester Grammar & 4  & 4 & 0 & 0 & 3     & 4.75             \\
Clifton College    & 10 & 9 & 0 & 1 & 9     & 4.5   \\



your table works here...
(see the attached pdf)

does the sample latex markup render correct in your scribus?
if not, the issue is that scribus does not find latex.
and you need to make sure that in "file > preferences > external tools" the there is a command that can call the pdf creator installed by your latex distribution (pdflatex being the default; you might need to use pdflatex or create a recipe for other creators).

if the sample does show correctly, does the table render correctly outside of scribus?


[attachment deleted by admin]


Hi a.l.e.

Thank you for taking the time to respond to my query. First apologies if I ask some dumb questions in the below.

The sample latex does not render in Scribus (or did you mean something different by 'markup'?). Other LaTeX (text, formulas, various formatting) does render fine in Scribus for me. Playing around in my native instance of LaTeX (on TeXWorks) based on your answer, it does not produce the file with pdfTeX but does with pdfLaTeX. I can also see from "Edit Source > Options" that I am using pdfTeX within Scribus, so I think you are correct in your diagnosis of the problem. (I used the "Rescan" button).

However (and here comes the dumb bit) I am not clear how to change this. Based on the above I think I need to get it to use pdfLaTeX instead of pdfTeX and I suspect that this is done through "file > preferences > external tools" as you suggest, but I don't understand how to actually do it. Could you be a bit more specific about what I need to do?



- do you have pdflatex installed?
- can you tell the path where pdflatex is?


Hi a.l.e.

I have pdfLaTeX installed (since I can access it via TeXWorks). I did try to find the pdflaTex path, but wasn't clear which exactly it was.

However a friend proposed an alternative solution that has worked. Calling \usepackage{booktabs} in the Fonts/Headers seems to do the trick.

Thanks for your help.


nice to see that you found a solution.

indeed, for latex and pdflatex -- as far as i recall -- table can directly used with no import.

texworks seems to be different there.


Agreed. Tables had always worked just out of the box for me, but I think that must be some configuration difference between pdfLaTeX and pdfTeX. I have almost always used Overleaf which I know runs pdfLaTeX, hence why I'd never encountered the problem before I guess.