Scribusoid

Author Topic: Scribus not recognizing newly installed fonts  (Read 5858 times)

mnawij

  • Sr. Member
  • ****
  • Posts: 329
  • Karma: 1
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #15 on: February 18, 2019, 11:42:39 pm »
I have installed 1.4.7 on all 3 previously mentioned OS's and all the fonts work, I am not sure why you are having that font related problem.  Since I cannot reproduce the problem, I am not sure that it is a bug...  There might be some other specific conflict with other installed apps or the Windows install itself.  If some other forum member would like to try and reproduce the problem to verify my findings that would be appreciated.  Sorry I could not be of more assistance.

mnawij

mroth1910

  • Newbie
  • *
  • Posts: 2
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #16 on: December 16, 2020, 02:58:20 pm »
Hello, I had the same problem with Scribus 1.5.5 (64-bit on macOS), specifically with the Google version of this font. I went back and found the individual files that I'd previously downloaded, between Octavio Pardo's Github repo and the original repo (I only downloaded fonts that Octavio hadn't worked on). The problem seems to be with the variable font file available from Google, ostensibly for reasons of size and organization.

RobSay

  • Newbie
  • *
  • Posts: 17
  • Karma: 0
  • Scribus User
Re: Scribus not recognizing newly installed fonts
« Reply #17 on: February 18, 2021, 05:54:38 pm »
I had a similar problem - but mine was not specific to the font file as fonts from different sources were not getting picked up.

This issue & resolution is specific to Windows ...  if the font was installed from a zip file or a double click .. Scribus didn't find it. The default behaviour for installing a font in Windows is for the *current user* only.

  • make sure you have a copy of the font file(s) somewhere safe
  • delete the installed font (from C:\Windows\Fonts or wherever)
  • go to your saved copy, right click on the font file and "install for all users"
    • restart scribus - and on the splash screen, you'll see "New font found.."
    [li]