Scribus > Raster and Vector Graphics

Unable to inport PDF into image frame




I'm unable to import PDF files into an Image Frame. I'm using Scribus 1.4.7 on a Windows 8.1 PC. Although the PDF is selected (and a preview shown) it isn't visible in the image frame. Other formats (PNGs / JPGs) work fine.

I have the latest version of Ghostscript installed (as of today 14 Feb 19) and specified in Preferences External tools (gswin64c).

I see other people have experienced this problem a few years ago, so wondering if there are any updated fixes / advice.

Many thanks.

Hi Little_Evenstar

First option is to always convert the pdf file to a high resolution image, there are several free options out there, just be careful with the online conversion sites, if anyone else has recommendations for a site, please suggest it.

To make any other suggestions I would need the pdf file in question to test and see what other issues could be arising... if you do not mind posting it here please do. Thanks!



Hello mnawij,

Thanks for the suggestion. I've tried this option in both Inkscape and Gimp. Unfortunately the images become very large, making it unworkable.

I know that the problem is not related to the PDF, as I experience the same problem, irrespective of the PDF file.

I've just installed Scribus and Ghostscript on my Surface Pro netbook (running Windows 10) and it seems to work on that machine. This suggests that there is something wrong with the setup on my Windows 8.1 laptop, but I can't seem to find it for the life of me!

Any other suggestions gratefully received.



Have you tried LibreOffice Draw, Xara, sK1 or other free pdf tools such as FoxIt, SumatraPDF, Nitro Reader, PDF-XChange Lite to "resave" the pdf file? Sometimes pdf files carry hidden cruft that needs to be removed and using another pdf application to resave the file will remove this and allow the pdf file to be placed.  It might also be a 'newer' version of pdf which is 1.7 + Adobe extensions that Scribus cannot interpret. I have ran into this problem with pdf files created from the newer Adobe Creative Cloud applications.  The newest pdf files from Adobe will not work in or be placed into Adobe Creative Suite 6 and older version... could be the same thing here.  Try to get the pdf version back to pdf v1.5 for placement.  Hope this makes sense.




Hello mnawij,

Apologies for the delay in replying.

Yes, I have tried to change the PDF, but still to no avail.

Instead, I've bought a new lap top running Windows 10, and all seems OK thus far.

Really not sure what the problem was or how to overcome it.

Many thanks for your helpful suggestions.


[0] Message Index

Go to full version