What do green squares with s inside mean for a font?

Previous topic - Next topic


I keep getting the error message that 2 fonts I use in a document are no longer available on my system. As you can see in the picture, they are still there in the replacement options. But what does the green square with the s inside before the font mean?

As far as I know, the fonts are ttf (at least in my font folder).

I fear that the type of font has changed and that I could loose quality when sending my doc to the printer.

[attachment deleted by admin]


hello moini

afaik this green square tells you that the font is not available. scribus is a bit picky with fonts...

if the fonts are installed on the system (or stored in a place, scribus is looking for), take a look at: 'file' → 'document setup' → 'fonts' and check if the font is selected to the use! if it is and scribus doesn't find it, then i suspect a faulty font file.

if you select a font with the green square in the replacement dialog, the font will neither be embedded nor outlined in the print file. if you are really lucky, the printer wil have the font on his system and everything works well. but i would not even hope for something like this...

try to replace the faulty font file by a good one or select a font that is available an your system!



it's been a long time since this thread was opened, but anyway, as this is the first context related result I got from Google in 2017, typing the keywords "scribus S fonts", and the solution posted here do not solve my problem, and as I have managed to find out a solution by myself, it may be useful for the next one searching this topic.

I had first installed the fonts I had in bulk in a folder, simply copy&pasting all the subfolders containing each font, into the .fonts folder in my home directory.
I have done this without using the terminal by doing so:
-Pressing Ctrl+H in home, will make visible all hidden folders.The way you tell Linux to create a hidden folder is simply by adding firstly a period to the folder name.
Thus, if you do not see any .fonts folder appear once you type Ctrl+H, you have to create one in your system because this is where all apps will search the fonts.
-Then you copy and paste all the folders containing the fonts in this .fonts folder, BUT from there may be the problem you are experiencing with the S font appearing in Scribus. While it's certainly better to have each font family in a different folder instead of having all the fonts files together pasted in .fonts folder, do not let the font files be located in a sub-sub-sub... folder from the first folder, i.e. do not nest too much the typeface files in order to avoid errors while loading or retrieving them from such deep locations from the system. Some of my typefaces, have been readed correctly by scribus even if they were located in a sub-sub-folder but for the two concerned by this issue, I solved it by allowing only to be present in a sub-folder of the .fonts folder as for example in my case:

Franz Gratzer

In my case (on Debian) all fonts installed reside in "/usr/share/fonts/truetype" and "/usr/share/fonts/opentype" etc. Originally I had created my own subfolder with my user name under "/usr/share/fonts" containing all the fonts I installed by hand. But considering the description in the first post here I moved all font files to the fitting original sub folders. That didn't help until I included all subfolders ("/usr/share/fonts/truetype","/usr/share/fonts/opentype","/usr/share/fonts/type1") as additional search paths. (So I guess my folder with the user name would have been fine also if had I only tried to include it as search path before moving all my custom fonts to the default sub folders.)

What puzzles me the most is why Scribus did find most of the other fonts even if the missing search paths obviously where a problem. All the fonts resided always in their usual folders and only some where installed by me in my user name sub folder. And many of those fonts in my customised folder where found without problems.

I am especially puzzled by this because it happened with basic fonts like "DejaVu", "FreeSans" and "FreeSerif" also. And those fonts came pre-installed with Debain, if I remember correctly. So I don't think I made any error with including them the wrong way.

At least now I understand why Scribus kept asking me for substitution fonts each time I opened the file even if I selected to remember those substitutions permanently. (I guessed the original documents might have been created with older versions of the same fonts maybe using different naming conventions. But I was obviously wrong.)