[SOLVED] Need help getting hanging indents under bullet points to align

Previous topic - Next topic


I have been struggling with getting the hanging indent settings for bullet points to work. I am on version 1.5.4.

Essentially, I want to be able to have the text on all lines of a bullet point to align left. The default seems to be for all lines after the first to align with the bullet point, rather than the line of text above it.

I can manually adjust things to look lined up, but it's not a good solution. How can this be done? Thanks!


By coincidence I am playing around with textframe properties in some experiments and I can ...
create a blank textframe
inject some sample text
insert character > bullet

and this gives the format you want (text on line 2 and after aligned left under bullet).

Are you inserting bullets in a different manner?

[Later Edit]
My apologies. After a second read of your post, I see that what I have is exactly what you report.
Text not aligned under the [bullet plus space].
I will play around further.


When I reply to these posts I learn something new every time.

I made a false start but after some more searching I found this script.


I copied the dated (deprecated?) python script and placed in /usr/share/scribus-trunk/scripts/

Your scripts may be in a different path.

Restarted Scribus, selected a paragraph in a textframe, Scripter > Scribus Scripts > Bullets
and a popup menu appears giving options.

The indented text is nicely aligned.

There might be another native approach but if there is one it is not too intuitive.

This old script at least works.


you can easily create an hanging indent in the main Scribus UI, but you have little control on the distances.

or you can create a "list" style and define its indent in a more controlled way.

don't forget to add a tab, since scribus does  "snap" to the indents.

[attachment deleted by admin]


moderation warning:

craiggomez, if you're a legit user, you're account has been hacked and a spammy footer was added.

since your questions seem to be ok, i've left them around... but i had to remove your account to avoid further dammages to this forum.
if you need an account, just create a new one.


I quite often 'overthink' problems in Scribus. Attached is a screenshot showing what you need to do to get auto-indented continuation lines from Scribus' automatic list feature. This is 1.5.5 on Windows 10. Use the distance from text and auto-indent controls rather than setting tabs or indents as you would for a  paragraph without list markers.

[attachment deleted by admin]


This solution doesn't seem to work on Scribus 1.5.8 on my Debian system. I don't know if this is a regression but the "Auto-Indent" checkbox currently does nothing. I've also been playing around with the tabs and can't get them to do what I want either.

The distance from text control works but I can't get the tabs to only indent the second (& subsequent) line(s). From my standpoint, it looks like the entire tabulator system is having problems doing what it says it is supposed to do.  :(

I was eventually able to get a list that looked OK by turning off the list and tab features (other than the bulleted list itself, with the bullet character. Then I inserted line breaks where necessary in the text, a space after the bullet character and 3 spaces after the line breaks. This is not ideal but it works until the developers get the lists and tabs features working again.


yea, the indents imho are a bit clunky
I have better luck typing the values in vs using the sliders
and finally realizing they are relative to each other and not absolute