Scribus vs MacOS Mojave

Previous topic - Next topic


Just installed Mojave and Scribus is not opening.  It gets hung during boot while setting colors.  Installed newest version 1.4.6.  Will 1.54 fix this?  Where can I get it?  Every time I try I end up with 1.46 instead.


Do you have many fonts installed?

On its first start, Scribus might be busy indexing them...

Otherwise, we have no report about Scribus now woring on OS X....


I have the same problem.  I just upgraded to Mojave 14 and Scribus 1.4.6 will not load.  I gets past the fonts loading and hangs on the color pallet.  I have had to force quit several times.  Help.


ok... personally i cannot test...

somebody (possibly one of you both) has now opened a ticket for it:

let's wait for the reply from the developer in charge of the dmg...


craig has replied:

"1.4.6 does run on Mojave. Maybe check your security settings or whatever (the warning will tell you), but it will work."

what is the error your are seeing?



Each time I try to start up Scribus by selecting an .sla file from Finder, the following occurs:
1. The usual startup screen opens and the initialization scripts begin loading.  Color wheel spinning.
2. The initialization for Color Profiles hangs for at least 30 mins, but the continues on. Color wheel spinning.
3. The initialization for User Shortcuts hangs for over an hour. I then just left the Mac to churn overnight. Color wheel spinning.
4. In the morning my file was open and displayed on screen, but was frozen. Color wheel spinning.
5. Locked up and have to Force Quit each session.

I have tried various other approaches all with the same result.  Scribus 1.4.6 will not run in Mojave 14 on my Macbook Air.


can you try to start scribus without a file?


I did try running Scribus without selecting an .sla file and I got the same behavior.  Then, I rebooted so there was nothing running in the background and tried opening Scribus without selecting an .sla file and I got the same behavior - unrecoverable hang on startup screen. 

What is curious is Scribus was working perfectly 10 minutes before upgrading to Mojave 14.  I made not system changes in security or anything else.  When Mojave was finished, I checked all of my programs and the only one that will not open is Scribus.  I am really stuck and hoping you can help me solve this problem as I use Scribus everyday.

Has anyone at your labs tested Scribus on a Mac after upgrading to Mojave 14 from High Sierra 13?


[moderation: please don't follow these instruction. look further down for the ctrl-click solution]

I solved the problem. 

First, I had to add the following command line in Terminal: sudo spctl --master-disable.  This gave me the option on the General tab of Security & Privacy to select "Anywhere" in the "Allow apps downloaded from: section.  This option has been removed from the latest versions of MACOS.

Second, on the Privacy tab, I unchecked Scribus in the "Allow the apps below to control your computer".

Once I did this and rebooted, Scribus opens like it did before.

Problem solved!


[moderation: please don't follow these instruction. look further down for the ctrl-click solution; while this solution has the same ffect, the next one is much easier to do]

randy, i've found a similar instruction in the internets... but i'm not sure that this is the best way to solve the issue.

i've further searched the topic and i've found a way to only authorize a single app.
this would work by typing in the terminal:

spctl --add /Applications/

(if your copy of Scribus is installed in the main Applications directory.)

but, in the past one could just ctrl-click (or use the right click) on the scribus icons and then click on "open" to allow the launching of Scribus.
does this not work anymore?
in my eyes, this would still be the preferred way to do that...


Your solution worked!  So:

1. I reversed what I had done yesterday.  In Terminal I gave the command: sudo spctl --master-enable.
2. In System Preferences > Security & Privacy > General tab, I disabled "Anywhere" from the "Allow apps downloaded from:" and selected the radio button for "App Store and identified developers".
3. I closed all apps and rebooted. 
4. I opened Scribus and it opened normally.

Thank you A.L.E. for a more secure method of enabling Scribus to run on Mojave!


I'm still not having any luck with this. I've tried all of the solutions here and none have worked. Does anyone have another suggestion?



have you managed to right click (or control click) the scribus icon and pick the open item?


Okay, it's been over a month since I was able to use Scribus. Can someone PLEASE help? I've tried all of the solutions here and none of them work!



if you right click on the scribus icon and pick the "open" command you will be able to open scribus.

since you're not explaining what is failing for you, i really cannot give you any further help.

i can only repeat my question: did you manage to right click on the scribus icon?