Development > Code

Compiling scribus with qt creator

(1/7) > >>

Gibbz:
Ok so im trying to build scribus so I can make some fixes.

I found this:
https://github.com/aoloe/scribus-manual-development/blob/master/content/getting-started/getting-started.md

So i have checked out the repo, open the project in qtcreator. When I try to build i get the error:


--- Code: ---actionmanager.h:34: error: QActionGroup: No such file or directory
 #include <QActionGroup>

--- End code ---

I cant seem to find any info on this online...

a.l.e:
I haven't checked it in a while...

If I recall it correctly, it should work...
I'm trying it out right now.

At first sight it looks more like a Qt misconfiguration rather than a Scribus issue... but I cannot be sure.

One question: what is your Operating System?

ciao
a.l.e

a.l.e:
Ok, I got it to compile but... it does not install correctly and the binary, then, cannot find the icons and shuts down...

- On the one side: what are you doing differntly? Are you on Linux? OS X? Windows?
- I will try to track what's the issue with the binary not being "make install"ed correctly
- I've added a section about Qt Creator: https://github.com/aoloe/scribus-manual-development/blob/master/content/qt-creator/qt-creator.md
  (for now, only a hint on how to get faster compiles by adding the -j4 flag for make)

(feel free to suggest edits and additions through pull requests, tickets, or comments in this thread...)

a.l.e:
I've updated https://github.com/aoloe/scribus-manual-development/blob/master/content/qt-creator/qt-creator.md with the instruction that got me a running Scribus compiled through Qt Creator:

- Building with -j4 to speed up the process.
- Corretly installed in a custom path (avoid /usr/local, as your parents always told you...).

Gibbz, if you need further help, you might come to the Scribus irc channel... (#scribus in freenode)

Gibbz:
Cool, adding the repo via qtcreator worked.
I had to use https://github.com/scribusproject/scribus.git instead as git one in the tutorial didnt have permission.

Im using manjaro linux (arch based)

Edit:
No icons found :(

Navigation

[0] Message Index

[#] Next page

Go to full version