Corrupted text causing #11 crashes

Previous topic - Next topic


I'm transferring a discussion from beginner forum, Trouble with "Get Text." I included it in that discussion as I thought it may be relevant to the other problem I was having. I believe that has been disproved so include the relevant parts of the post for Fonts and Typography. I'll include dates when they were posted. I am working on a Mac with High Sierra.

(Posted April 13, 2018) I'm a bit concerned about my text. I should explain what all I had to go through to get it. I began with MS Word and had huge amount of corruption and weird behavior. Eventually, I dumped Word. To purify the text, I took a screen shot of each page and used the ocr in Adobe Acrobat to get the text. Some words did not look right, so I retyped them either ahead or behind in the middle of another word and cut the offender. Then I put this text in an online compare document program, and compared the text with the original. I corrected the new text there and copy and pasted into Text Edit.

(Posted April 14, 2018) Should someone want to examine the text causing the #11 crashes, I'm attaching an .sla with the two paragraphs I've been attempting to add text as a subtitle in between. Details at the end. (Note: should you want a look at this corrupted text, you'll have to get it from "Trouble with Get Text" as I have since removed Georgia from my Font Book.)

( Posted April 14, 2018, later) I think that some new corruption may remain in the text from this process as some pretty ordinary words are not being recognized by spell check. Now that the program is working all right with it, should I trust it? Or will it create trouble down the road? I tried attaching a sample .odt but this program will not accept that so converted to .doc.

(Posted April 14, 2018) I have new information. The odt that I downloaded apparently still contains some corruption from the PDF-OCR process. Some was obviously there at the time, some words simply did not look right. I thought I got rid of it, Acrobat's Preflight gave them a green light — but evidently not. I was able to try Datanumen's Word Repair (in my old PC that works only occasionally) on the odt document that produced the crash today. It says it is corrupted and unable to repair it. Why my computer is more susceptible to this corruption than yours? Probably something to do with corrupted fonts on mine (that Font Book's verification can't detect). It seems best to simply do a clean download of High Sierra and keep any previously constructed odt's and PDF's and Word docs off.
I've changed the fonts in the document and will try it again in Datanumen, if the PC comes back (it's currently back in black screen and starting up in safe mode doesn't work).

(Posted April 16, 2018) My PC is still stuck in black screen but I tried the test of changing the font from Georgia to HK Serif in a the problem odt and the styles in Scribus. Now there is no problem with putting that subtitle in. I'll be interested in seeing if Datanumen will be able to repair the document after this change.


hi remadepreacher

i try to help people with their scribus problems – but what you do here (yust recollecting your posts and 'ceaning' them from the recommended solutions) instead of trying some of the recommended ways to get rid of your problems, could lead me to ignore your future posts...



hi remadepreacher

i think that you should look for local (in real life) computer support and get them to help you.
probably, your organisation has somebody who is in charge of the computer infrastructure.

your latest posts make little sense to me, and somebody who sees your computer and what actions you're performing will probably better be able to help you.

and as utnik said, stick to one single thread for the same question. if an administrator thinks there is a need for a split, a merge or a move she will do it.
(but if you  have new questions, please open a new thread, don't keep on asking further questions in the same topic. thanks!)


My putting this thread here was merely my way of trying to correct a mistake — putting a different problem in with my trouble with getting text and typing in a text box.

Sorry, utnik you're right, I should have included the following replies:

"Hi remadepreacher

I just opened your file in scribus 1.5.3, inserted 'Trouble In Paradise' between the two paragraphs and changed the paragraph style to 'heading 3' – there is no crash on my system (high sierra – the same as you use...)

Either there's something wrong
* with your scribus installation → to check this you could close scribus, and remove the directory: /users/'your user name'/library/preferences/scribus from the library or rename it to 'scribus_old' and restart scribus.
* or with the os itself (unlikely but possible)
* or with one of the fonts you use  → check your fonts with ''. ('hk serif' was replaced in my test, but it isn't in use in the test file...)
* or you do something strange...
as your file won't open in scribus 1.4.6 without conversion, I tested only with 1.5.3."


April 15, 2018
"As i wrote in the bug tracker, you should try to isolate the problem by testing parts of your complex workflow separately, instead of changing everything (new operating system, new font files...) at the same time.
if a car wouldn't run, your solution could be to change the battery, the injector pump and all the ignition plugs before a real 'bug hunting attempt' would lead to an empty fuel tank..."


I do appreciate your test and the suggestion of isolating the problem with the text before changing everything.
This led me to switch out Georgia in the document and see it's relation to the crashes. This led me to remove Georgia from my Font Book (I'll download it again when I decide if it worth paying for its use in the book).