Scribus > Text and Typography

Numbering and page numbering using Devanagari numerals

<< < (2/2)

Ewac:
I know this is an old topic, but I have the same issue with the Khmer language. I already filed a bug reply and requested Khmer to be added in the list of number styles for page numbers and lists...
However, I wonder if anyone has found a work-around that I could use in the meantime. Something that is more efficient than C&P a text frame and manually adding the numbers on each page..

Ewac:
Just if someone else is looking for this topic later...The "work around" that I found is to use a font that uses arabic numbers, but displays them as the number in the foreign script. This font is not using the unicode for the foreign script.

So the input the computer gets is 1 2 3 4 5... but the font will make it look like ១​ ២ ៣ ៤ ៥

This works for Khmer and hope this might help others who work with different scripts as well.

muhammodmasum:
Hi,

I'm also searching the way to use Bengali numbering for pages.
Thanks

Ewac:
Ok, so I thought I would write a little bit more about what I have found to work well for me (working with Khmer fonts) and what I believe to be helpful for others working with foreign fonts. I'm no professional, so please correct me if my understanding is wrong.

By default Scribus is using the unicode symbols for latin numbers (U+0030 till U+0039 for the numbers 0 to 9) to create the automatic page numbers, footnote numbering, numbered list etc.
Under file / document setup / sections / style you can chose different other numbering systems. However, many other scripts and their numbering systems are not included in this list. As much as I would like Scribus to include more numbering systems here, I don't think we can expect the volunteer developers to enable this for all the many languages out there.
So the solution I found to be able to use the Khmer numbering system was to use a font that replaced the shape of the Latin numbers in their unicode position with the shape of the "foreign" number. Hence if you "type" U+0031 the shape displayed will be a "១" instead of a "1" (for Khmer).

Simply using a font for your script (Devanagari, Khmer, Bengali or whatever other script) will not work, because the numbers of those scripts each have their individual, respective unicode number reference. (for example U+17E0 till U+17E9 for the Khmer numbers 0 to 9). Therefore, even if you use a font that has the numbers of your script, Scribus will not display those numbers, because they have a different unicode reference, but rather Scribus will display whatever symbols that are in the place of U+0030 and so on.

Since I did not like the available fonts for my language which were set up in the way I described above, I created my own custom font. This would also be the solution for those who do not have such a font available for their script.

Here is what I did:
I used FontForge, a freeware program for creating and editing fonts.
I chose the Khmer font that I wanted to use for numbering of pages, footnotes, etc. and saved a copy of it to be my custom font.
I copied the vector shape of the Khmer number "1"  which is ១ (U+17E1) and pasted it in replacement of the Latin number "1" (U+0031)
Repeated that with the other numbers, saved the changes and use that custom font for the page numbers etc. in Scribus.

This sounds a bit complicated at first, but I was able to figure it out fairly quickly with a little bit of research and having set up this custom font once now saves me tonns of work, time and headache.
By the same principle you can also combine two fonts in their "entirety", which can sometimes be helpful when working with bilingual documents (but remember that each unicode position can only be filled once, so you might not want to replace latin numbers, if you want to use those as well).

I hope this is explanation is a help for others who are facing the same situation!

Navigation

[0] Message Index

[*] Previous page

Go to full version