New user, help with bold L's in PDF, not outlining fonts

Previous topic - Next topic


This is the first time posting here and the first time creating a PDF form. I made a big form, I used the TT fonts Fjalla One and Roboto (regular and medium) for the fonts.

I used the print functionality for Nitro Pro, my PDF editor, to export to PDF. Everything looks great in Nitro, but in Acrobat (DC or Reader) the lower case l's are all ridiculously bold. I understand from my reading that this happens when fonts are outlined instead of embedded and that some fonts can't be embedded. I set all three to embed and not subset in Scribus fonts settings, and set them to embed in the Nitro dialog. Same results.

I also tried using the Scribus PDF exporter with all fonts embedded, same results.

Then I tried changing out fonts. Fjalla looks perfect, so I kept that, but I switched out Roboto for both Open Sans then Arial. Exact same results - I ticked the box to embed all fonts in both Nitro and Scribus PDF export, the lowercase L's are still extra bold and wide.

I don't know what to do now - what font or setting do I have to use to get this to look right when viewed online? They look bad (but not as bad as Acrobat) in Chrome's PDF viewer too.  :(


hi kanjigirl

did you check which fonts are really embedded in the .pdf file? (in acrobat reader: 'ctrl' + 'd') – could be interesting...

some of my fonts with a straight 'l' and without embedding problems are:

  • cantarell
  • catamaran
  • fira sans
  • lato
  • liberation sans
the mjority of my font embedding problems i had with microsoft standard fonts (which i never use with my own files...)


Hmm, I tried CTRL+D in the one with Fjalla and Arial with Roboto on other pages - I see Arial and Roboto are not embedded (and looks awful).

I changed the Arial back to Open Sans and then set all fonts to embed in the PDF export. This looks perfect! I think I missed the embed step when I was testing Open Sans yesterday.

Thank you! Now at least I know what to look for in Acrobat if it looks wrong.