Scribus > Linux

Help Installing RC6 tar.bz2 in Ubuntu 11.10

(1/2) > >>

brohan:
I have been using Scribus on Windoze for quite some time now, and my files are saved as RC5. I am switching to Ubuntu 11.10, and trying to install RC6, so I may open my files made in Windoze RC5.  When I add the Repository to Ubuntu Software Center I can only get RC2, not a help in my situation.  I am therefore trying to install RC6 from the .tar.bz2 download.  I have unpackaged the file in /home/username/Scribusinstall  I have also made another directory there called builddir.  I opened the Install4 file and was able to install all of the debian files except for python2.3-dev which I could not find, but have python-dev, and I was not able to find libcupsys2-dev. When I try command line to get libcupsys2-dev I get the message "Note, selecting 'libcups2-dev' instead of 'libcupsys2-dev'"

All of this to say when I go into the builddir and try to cmake scribus I get the following errors:


CMake Error at styles/CMakeLists.txt:20 (QT4_WRAP_CPP):
  Unknown CMake command "QT4_WRAP_CPP".


CMake Warning (dev) in CMakeLists.txt:
  No cmake_minimum_required command is present.  A line of code such as

    cmake_minimum_required(VERSION 2.8)

  should be added at the top of the file.  The version specified may be lower
  if you wish to support older CMake versions for this project.  For more
  information run "cmake --help-policy CMP0000".
This warning is for project developers.  Use -Wno-dev to suppress it.

-- Configuring incomplete, errors occurred!
 





I then installed Synaptic package manager, installed the key, and can see RC6 in available packages in Synaptic. When I try to install via Synaptic, I get an exclamation point in the box, when I proceed it says Fix Broken Packaged First. When I go to Edit Fix Broken Packages I get the following:

E: Unable to correct problems, you have held broken packages.
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependen

When I then try to install via terminal I get the following:

The following packages have unmet dependencies:
 scribus-ng : Depends: libaspell15 (>= 0.60.7~20110707) but 0.60.6-6 is to be installed
              Recommends: icc-profiles but it is not going to be installed
E: Unable to correct problems, you have held broken packages.


I do have libaspell15 .60.6-6 installed already. I do not see .60.7 via Ubuntu Software Center or in Synaptic.  I did download libaspell15_0.6.7~ but when I click open and open it in Ubuntu Software Center, it says it will break dependencies, and does not install.

Any suggestions for trying to install this way, or manually?

Meho R.:
What a mess! Don't bother with manual installation, rather install Scribus via Synaptic. To fix broken packages, try running the following command in Terminal:

--- Code: ---sudo apt-get install -f

--- End code ---
After things get fixed, try installing scribus-ng from Synaptic again.

brohan:
I did what you suggested, to me it doesn't look like anything happeend:


bjrohan@bjrohan-MM061:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 8 not upgraded.
bjrohan@bjrohan-MM061:~$


Do I need to undo my manual install mess with the items I installed that were dependent packages first? Also may there be a conflict with the stock Ubuntu Software Center and Synaptic?

Thank you for your help.

Meho R.:
Hmmm, it seems that Ubuntu ditched libaspell15 provided by Debian Testing and replaced it with some their own one, but version 0.60.6. I really cannot be of further help regarding this dependency issue, since I don't use Ubuntu. You can ask at Ubuntu forums, IRC or Scribus mailing list for assistance, in case no Ubuntu users come by this thread.

Synaptic and Ubuntu Software Center shouldn't conflict, they're both basically just graphic front-ends for apt.

brohan:
My issue was a basic one. I need to scroll further down the packages page, and use the Ubuntu 11.10 repositories, I was using a different one.

Navigation

[0] Message Index

[#] Next page

Go to full version