PDF doesn't print properly, but looks fine in Print Preview

Previous topic - Next topic


Hello everyone,

I've followed many Scribus tutorials and videos on YouTube, and can't seem to find a solution for this, so hopefully a kind soul here will point me in the right direction!  The newsletter I'm creating has a top banner on the first page, and then they're mostly articles.  The front page also has a table of contents, which I've figured how to generate.  The problem is, when it's time to export as a PDF, it looks fine in print preview, but for some reason, when it gets converted as a PDF, the front page text and table of content disappears!  Is this is a bug or am I doing something wrong?  I've included a few attachments to make it as clear as possible.

Other info:

  • I'm using PDF 1.5 to export.
  • I'm using a Mac, and Scribus version 1.4.3 (C-C-T-F-C1.12.14-Mac/Aqua)

Thanks for your help.

[attachment deleted by admin]


MrBoji, have you been using layers?

If your table of contents (TOC) and article are on a separate layer it's possible that you've set that layer to be "non exportable/printable", possibly by accident. If you look in the "Layers" dialog - "Windows -> Layers" - you'll see a list of the available layers. The column with the little printer icon determines if each layer can be printer/exported. Tick it to allow export/print.

Or, are you using the "Include Layers" option in the "Export as PDF" dialog? (This is only available on PDF 1.5.) If so, you could try switching this off and see what happens.

If the problem isn't that, you could select the TOC and article frames - one by one - and look in the "Properties" palette under the "X,Y,Z" tab. In there is another little printer icon that does the same as above but just for individual objects. If there's a little "minus/stop" sign in the icon then it's set to not print/export. Just click it to reverse this for each object that is wrong.

And, is there some reason you need PDF 1.5? Have you tried 1.4 instead? Do you get the same problem?

If the problem is not related to any of the above - they're just the simplest fixes - then just say so.


Hi Garry,

Thanks for trying to help me out.  I went through the possible solutions you listed, and none of them worked unfortunately.  All text boxes have the export/print option checked, and I tried printing with PDF versions 1.4 and 1.5.


hi mrboji

if you could upload an archive containing the .sla file with fonts and images, i would take a look at it.
it must not be your work file. a dummy with sample text that shows the same problem will work as well.



MrBoji, I think the problem is with the font(s) you are using.

Opening the PDF with OSX Preview has the text missing, which is what you get.

Opening it with Skim 1.4.2 also has the text missing.

However, opening it with Adobe Reader 9.5.5 (Mac) displays the text but with a message "Cannot extract the embedded font 'AvenirNext-Regular'. Some characters may not display or print correctly."

So it looks like Reader has defaulted to another font whereas Preview, Skim, and whatever software you are using have simply ignored the "broken" font and displayed nothing.

Try using a different font or getting another copy of whatever font you are trying to use.

I have no idea what the problem with the font is but, as utnik suggests, uploading the archive might give someone a chance to look into it further.

If you absolutely have to use that specific font you can always outline it instead of embedding it but there could be - depending on the amount of text - file size issues. You'd need to make a judgement there yourself.


Dear Garry and Utnik,

I really appreciate you taking the time to help me out.  You might be right--I installed Scribus on a Windows machine, which didn't have the Avenir Next font, but substituted it with Arial, and the text displayed correctly when I generated a PDF file from the document. If using Arial or another standard font is all it takes, then I'll use that, not a problem.

What I'm left scratching my head with, however, is that the "Mindfulness Community" text in the top banner disappears in the PDF version, and am wondering why this happens.  This is written in Arial as well.  I've attached all of the necessary documents as an archive to make it easier for everyone.

I'm so happy to think that I'll be able to use Scribus!  Almost there!

[attachment deleted by admin]


I've just opened the SLA and the "Mindfullness Community" text frame has the little printer icon with the "minus/stop" showing in the Properties palette (as mentioned above).

That's easy enough to overlook when you're troubleshooting.

Just clicking it - to allow export/print - and then exporting the PDF works fine for me.


I can't believe it, it works!  Wow, thank you so much GarryP and Utnik for helping me out.  I am so grateful for your help--now I can use Scribus as my main desktop publishing software.

Again, thank you!


HELP!!  I have tried "print as image" and tried to resave the file as a PDF and nothing is working.  It still prints a very small part of the a column of the poster and nothing else.

[attachment deleted by admin]


hi davery17

no idea what you are doing, but you should "file > export > as a pdf", if you want a pdf...