Story editor does not update, text gets jumbled, characters stuck in buffer?

Previous topic - Next topic


This is a very difficult problem to search for a solution.

I have actually reported this as a bug, however an admin repied to say that he didn't have the problem, therefore it isn't a problem.

I always edit text in the story editor, so I click on a text frame, press Ctrl T and the story editor opens, usually as a background window which I have to bring to the front. I position the cursor where I want to edit and start typing. Nothing happens. I close the story editor window.

When I then press Ctrl T to go back into the story editor, Scribus executes whatever was in the keyboard buffer on the whole text frame. If I had previously tried to delete text, Scribus now deletes the entire text frame. If I had previously pressed the right cursor arrow to move the cursor right, it moves the text frame right by as many steps as I pressed the right arrow.

If I close and reopen the story editor a few times, it then works normally. However, the problem will recur several times throughout any instance of using Scribus.
I am running 1.4.0 rc6 and I have uninstalled and reinstalled 3 times, deleting the home/me/.scribus folder and all of its settings.

Story editor is now pretty much unusable, which is annoying. I know that a lot of people prefer to edit text on canvas but I don't, I like the story editor's control, ease of use and speed.

This problem gets worse the more I am forced to use the on-canvass editor instead of the story editor.  I am editing a large block of text on the back of a book cover, and as I type, not all of the letters make it into the text frame, for example "may think that this book can" becomes "may tthn btooan tan ta".

But that's not all, when I press backspace, I don't get a backspace, I get the next character that I had typed before characters stopped displaying. If I press backspace enough times, I get all of the remaining characters out, in no discernible order, and then I eventually start getting backspaces.

And is it a keyboard hardware problem?

I thought so at first, when I plugged in another keyboard and it worked... the first 3 times I tried. Then it stopped.

If I unplug the keyboard (USB) and plug it back again, the problem goes away for about 3 editing attempts, then it's back.

I also tried the OnBoard on screen keyboard to rule out a hardware problem. Same thing happens.

I'm at my wits end because my job depends on using Scribus, and right now it is becoming completely unusable, I have to all my text editing somewhere else as all I can do is copy & paste.

It's happening in other dialogue boxes too. I can't even edit colours now. To add a new colour, I have to type the colour's name in a text editor, copy it an paste it into the edit colours dialogue box with a mouse right click.

And Scribus is the only software I am having this problem with.


What operating system do you have?

If you are running some Linux distro, what window manager are you using?

I think it sounds like a Qt problem.


Thanks you Nermander! It's a big relief just having someone suggest a direction to look in!

I am running Ubuntu 11.04, my window manager is Metacity (I like it simple).

I have checked my package manager and all qt libraries are up to date.

I could try a different shell like xfce and see if the problem still occurs.


as written in the bug tracker:
since you are using ubuntu you can try this: install "Qt 4 Settings", run it, and choose "Cleanlooks" as GUI style...
xfce will probably also solve your problem


Thanks to both of you - I installed Qt 4 settings, set the gui style to Clearlooks and the same within Scribus' own preferences and I was overjoyed that it all worked as it should.

However, I thought I'd wait a couple of days before replying, just to make sure.

Good thing I did. The problem is back, exactly the same as before.

It seems that if I do something that affects the keyboard's state, such as un/replug it or try a different one or change the Qt settings, the story editor work for a while, then it gets 'stuck' again.

I could try xfce but to be honest, I don't want to have to log out of gnome and back in again every time I use Scribus, and I'm certainly not going to switch to xfce full time.

Any thoughts on what I can try next?


I've started a new thread elsewhere, because I upgraded to Ubuntu 11.10 and now Scribus won't run at all, it crashes with signal #6, regardless of whether I am running Gnome, Unity, Xfce.,268.0.html